Ask Your Question
0

Either mate or cinnamon have toasted my gnome3 desktop. How to fix?

asked 2013-06-04 21:31:29 -0500

boyd gravatar image

updated 2013-06-04 21:34:02 -0500

I was trying out both mate and cinnamon, (on fedora 19) and have decided that gnome3 is really just fine. Only problem is that after reverting to gnome3 one or the other has caused the icons to show on the desktop permanantly. I have:

used gnome-tweak-tool and enabled/disabled the file manger handling the desktop. yum remove mate-* libmate* cinnamon muffin nemo-* mv ~.config ~.config.old; mv~.local .local.old; rm -fr ~/.cinnamon yum remove gnome-shell-extensions-* rm -fr ~/.local/share/gnome-shell/extensions

Still icons on my desktop!!! Then:

created a new account and even then a new user gets icons on the desktop.

Where is this setting coming from?

(In the mean time will install a kvm and try to reproduce this.)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-06-04 22:45:48 -0500

FranciscoD_ gravatar image

This shouldn't happen. If you can reproduce it, please file a bug. In the mean time, check the output of:

$ gsettings get org.gnome.desktop.background show-desktop-icons

If it's true, reset it to false:

$ gsettings reset org.gnome.desktop.background show-desktop-icons

Hopefully, that should fix it. The new user also seeing them points at a system configuration though so it might not work for new users.

edit flag offensive delete link more

Comments

Yep, that was it. Thanks buddy!

boyd gravatar imageboyd ( 2013-06-04 23:58:58 -0500 )edit

@boyd can you please mark the answer as correct? https://fedoraproject.org/wiki/Askfedoraguidelines

FranciscoD_ gravatar imageFranciscoD_ ( 2013-06-05 08:39:47 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-06-04 21:31:29 -0500

Seen: 784 times

Last updated: Jun 04 '13