Ask Your Question
0

Cant start httpd- no acces to my localhost

asked 2013-04-24 00:27:48 -0500

Fishes gravatar image

updated 2013-09-02 01:36:24 -0500

baptistemm gravatar image

So.. first of all, im kinda new at fedora and kde. Yesterday i succesfully installed and started my lamp, i even could see my localhost - php info file. Today i turned my pc on, and i couldnt enter my localost!

Console:

[root@127 64]# service httpd start
Redirecting to /bin/systemctl start  httpd.service
Job for httpd.service failed. See 'systemctl status httpd.service' and 'journalctl -xn' for details.

Systemctl:

[root@127 64]# systemctl status httpd.service
httpd.service - The Apache HTTP Server
          Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
          Active: failed (Result: exit-code) since sze 2013-04-24 07:22:02 CEST; 4min 55s ago
         Process: 14381 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=1/FAILURE)
         Process: 14378 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)

ápr 24 07:22:01 127.0.0.1       fedora httpd[14378]: AH00526: Syntax error on line 119 of /etc/httpd/conf/httpd.conf:
ápr 24 07:22:01 127.0.0.1       fedora httpd[14378]: DocumentRoot must be a directory
ápr 24 07:22:02 127.0.0.1       fedora systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
ápr 24 07:22:02 127.0.0.1       fedora httpd[14381]: AH00526: Syntax error on line 119 of /etc/httpd/conf/httpd.conf:
ápr 24 07:22:02 127.0.0.1       fedora httpd[14381]: DocumentRoot must be a directory
ápr 24 07:22:02 127.0.0.1       fedora systemd[1]: httpd.service: control process exited, code=exited status=1
ápr 24 07:22:02 127.0.0.1       fedora systemd[1]: Failed to start The Apache HTTP Server.
ápr 24 07:22:02 127.0.0.1       fedora systemd[1]: Unit httpd.service entered failed state

Anyone know what is the problem? Thank you for your help, and good day for everyone!

edit retag flag offensive close merge delete

Comments

1

the error message speaks for itself, your configuration is wrong at line 119. Open the file /etc/httpd/conf/httpd.conf and correct it. As a general advice, upon each modification and before restarting apache, launch the command apache2ctl -t to validate the written configuration.

baptistemm gravatar imagebaptistemm ( 2013-09-02 01:42:00 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-04-24 07:54:04 -0500

ThomasMcA gravatar image

The DocumentRoot setting in your httpd.conf does not point to the root of your web server - it may be pointing to a directory that does not exist.

edit flag offensive delete link more

Comments

Logs are messy looking at first glance, but they usually do have all you need :)

"Syntax error on line 119 of /etc/httpd/conf/httpd.conf" "DocumentRoot must be a directory"

Can you post your httpd.conf:119 and an ls of where your DocumentRoot points to on your filesystem, OP?

wholevin gravatar imagewholevin ( 2013-04-25 06:47:08 -0500 )edit

Question Tools

Stats

Asked: 2013-04-24 00:27:48 -0500

Seen: 4,917 times

Last updated: Sep 02 '13