Changing keyboard input language

asked 2013-04-14 17:07:03 -0500

Leonardo gravatar image

Hi,

I'm having trouble in setting up fedora with the correct input language. My primary language is Portuguese (Brazil) but my laptop is from USA so my keyboard layout is "English (US)". The problem is if I leave the input method as English (US), I can't type letters with accents (example, ã, ç, á, à, õ, and all variations). On Windows We could fix this by choosing the "Input Language" as Portuguese (Brazil) and set the "keyboard layout" as English (US). In fedora we don't have this option. I tried using English (US, alternative international) but although it fixes the portuguese accents it screws the rest for example, I can't type: "I've" when I do it outputs: "Iǘe" and other stuff gets screw too.

Simplifying my question is: How can I get Portuguese accents to work on US keyboard ?

edit retag flag offensive close merge delete

Comments

Some time ago I had a notebook with English keyboard, and I remember configuring it with an option like "with dead letters" or something like that, and that solved my problem because I live in Brazil and need letters with accents too.

skytux gravatar imageskytux ( 2013-04-14 23:49:13 -0500 )edit
1

skytux, I tried the option with dead letters and others keyboard layout and although it fixes the accents in portuguese, I can't type in english anymore as the problem in the last part of the question starts to happen. At least not in the usual way, looks like I need to get used to the new layout. Typing in english now requires using the Alt Gr to use the single quote and all stuff.

Leonardo gravatar imageLeonardo ( 2013-04-16 17:17:45 -0500 )edit

Good luck with that! :)

skytux gravatar imageskytux ( 2013-04-16 18:06:11 -0500 )edit