Ask Your Question
0

Can't seem to mount iphone 4s in fedora 18

asked 2013-04-07 13:23:43 -0500

roznoshchik gravatar image

updated 2013-04-07 23:31:15 -0500

FranciscoD_ gravatar image

Hey, I have a jailbroken iphone 4s running ios 6 a friend just installed fedora 18 on a laptop. I've never used linux before but am generally tech capable.

googling didn't yield any answers to this but i cant seem to see my iphone neither in the files explorer nor in rhythmbox.

after some more toying around, it seems i can't mount an android device either. Usb sticks work fine but maybe this is a problem with a larger drive?

i looked through terminal and seem to get the following error as visible in dmesg: usb 1-2: device descriptor read/64, error -71 fedora18

I did some more troubleshooting and realized i didnt have ifuse installed. After installing it I get the following dmesg error:

[  727.407487] usb 2-2: Manufacturer: Apple Inc.
[  727.407490] usb 2-2: SerialNumber: 9e21ab4af31a21a344e75521e50fdf5f0d7e794a
[  727.441937] ipheth 2-2:4.2: Apple iPhone USB Ethernet device attached
[  727.532057] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  728.115475] ipheth 2-2:4.2: ipheth_rcvbulk_callback: urb status: -75
[  728.250152] hub 2-0:1.0: port 2 disabled by hub (EMI?), re-enabling...
[  728.250162] usb 2-2: USB disconnect, device number 7
[  728.255079] ipheth 2-2:4.2: Apple iPhone USB Ethernet now disconnected
[  728.462054] usb 2-2: new full-speed USB device number 8 using uhci_hcd
[  728.573052] usb 2-2: device descriptor read/64, error -71
[  728.804110] usb 2-2: device descriptor read/64, error -71
[  729.007099] usb 2-2: new full-speed USB device number 9 using uhci_hcd
[  729.139479] usb 2-2: not running at top speed; connect to a high speed hub
[  729.207483] usb 2-2: New USB device found, idVendor=05ac, idProduct=12a0
[  729.207487] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  729.207491] usb 2-2: Product: iPhone
[  729.207494] usb 2-2: Manufacturer: Apple Inc.
[  729.207497] usb 2-2: SerialNumber: 9e21ab4af31a21a344e75521e50fdf5f0d7e794a
[  729.258952] ipheth 2-2:4.2: Apple iPhone USB Ethernet device attached
[  729.339969] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[  766.714389] SELinux: initialized (dev proc, type proc), uses genfs_contexts

any advice?

I was able to plug in an ipod classic and had no trouble mounting it, but i cant mount my jailbroken iphone or an lg g2x android phone.

I don't have access to a non jailbroken iphone at the moment to try to see if it works or a non lg android phone.

Thanks, RR

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-07 23:33:49 -0500

FranciscoD_ gravatar image

I don't know about the iphone 4s. I have no idea what protocol it uses. For android, which uses MTP, you can use tools from a package called simple-mtpfs

sudo yum install simple-mtpfs

Read the docs for the package to see how it works:

simple-mtfps --help
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-07 13:23:43 -0500

Seen: 1,282 times

Last updated: Apr 07 '13