Ask Your Question
0

PHP on local machine only works with created files

asked 2013-04-06 20:53:08 -0500

devShuba gravatar image

Hi,

I was going through this tutorial here http ://fedorasolved.org/server-solutions/lamp-stack

to set up my local machine for php files. The problem is that when I copy my index.php from my external hard drive into that folder my browser tells me a German message, I'm trying to translate it

server error
There has been an error trying to call localhost/index.php     
Either its configured wrong or its maintained

When I create an index.php in that folder with EXACT the same content it works. Why is that so? How can I solve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-04-06 21:40:10 -0500

ThomasMcA gravatar image

It sounds like the permissions are wrong on the file when it gets copied from the external hard drive. By default, Apache runs as a user called "apache", so that user must be authorized to read files accessed via your local web server.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-06 20:53:08 -0500

Seen: 279 times

Last updated: Apr 06 '13