Ask Your Question
1

F18 hdparm ignores spin down

asked 2013-03-31 10:03:10 -0500

cepielka gravatar image

Hi,

I have just installed F18 with mate desktop (netinstall) as a replacement for my ubuntu storage box, because I need to install something what is not supported on debian based systems. I have a problem with hdparm; it does not spin down my disk drives after specified time, i.e. after manually issuing hdparm -S 121 /dev/sd[bcdefg] says that it will spin down however it does not spin down anything. Putting disk drives manualy into standby using -y switch however works and disk drives are sleeping.

I have already disabled smartd service, which I thought that it is causing this issue, however it didn't help.

Could you please advise what could be the problem?

PS: Please note, that I'm still a beginner when it comes to Linux.

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-28 14:24:10 -0500

ykill gravatar image

updated 2016-05-28 14:24:56 -0500

You can look at this with either hdparm or with smartctl. Have you checked to see if the drive has apm on?

Try using smartctl to make sure that the drive is configured to spin down:

$ sudo smartctl -g apm /dev/sdA

where A is a single (spinning) drive letter, like b, c, d, e, f, or g.

Man smartctl says:

standby,[N|off] - [ATA only] Sets the standby (spindown) timer and places the drive in the IDLE mode. A value of 0 or 'off' disables the standby timer. Values from 1 to 240 specify timeouts from 5 seconds to 20 minutes in 5 second increments. Values from 241 to 251 specify timeouts from 30 minutes to 330 minutes in 30 minute increments. Value 252 specifies 21 minutes. Value 253 specifies a vendor specific time between 8 and 12 hours. Value 255 specifies 21 minutes and 15 seconds. Some drives may use a vendor specific interpretation for the values. Note that there is no get option because ATA standards do not specify a method to read the standby timer.

This seems to be the same numbers you are using with hdparm, so if hdparm is not setting the spindown, try using smartctl to set it to 121, and then check it afterwards. Maybe you want to go back to using the smartd setup, rather than hdparm?

$ sudo smartctl -s apm,121 /dev/sdA
smartctl 6.5 2016-05-07 r4318 [x86_64-linux-4.4.8-300.fc23.x86_64] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF ENABLE/DISABLE COMMANDS SECTION ===
APM set to level 121 (intermediate level with standby)
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-31 10:03:10 -0500

Seen: 457 times

Last updated: May 28 '16