Ask Your Question

slow internet speed in fedora 18

asked 2013-03-25 10:09:28 -0500

kushwa gravatar image

updated 2013-08-06 08:07:29 -0500

FranciscoD_ gravatar image

i have DSL internet connection but the speed is low as compair to the windows i also turn off the ipv6 in mozilla but it would not help to improve the speed /

edit retag flag offensive close merge delete


Could you check, that you are using the same network settings in Windows and Linux? eg. DNS, compressions...

none gravatar imagenone ( 2013-08-06 09:37:50 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2013-03-25 15:47:24 -0500

ThomasMcA gravatar image

updated 2014-02-20 09:33:57 -0500

Bucic gravatar image

1) Disable IPv6 in Fedora by adding the following lines to the end of /etc/sysctl.conf

# Disable ipv6

1a) comment out IPv6 hosts in /etc/hosts OR 1alt) simply disable the whole ipv6 stack by adding ipv6.disable=1 to your GRUB command line in etc/default/grub 2) Reboot

3) Test your Internet speed using on both Windows and Fedora. Are the speeds still different? If so, how different?

Note: Some updates may reset the contents of /etc/sysctl.conf


edit flag offensive delete link more


lsmod | grep ipv6 returns some ipv6 bits. Does it mean your method doesn't work?

Bucic gravatar imageBucic ( 2013-03-26 13:01:01 -0500 )edit

Did you reboot? On my F16 system, that command returns nothing.

ThomasMcA gravatar imageThomasMcA ( 2013-03-27 12:18:45 -0500 )edit

@ThomasMcA Yup, I did. It's still there, e.g. nf_conntrack_ipv6 18782 23 Are you sure you provided the latest/most recommended method of disabling IPv6?

Bucic gravatar imageBucic ( 2013-03-27 12:54:55 -0500 )edit

It looks like some systems need 2 lines in sysctl.conf. I have edited my answer to reflect that.

ThomasMcA gravatar imageThomasMcA ( 2013-03-27 14:13:55 -0500 )edit

Same return of lsmod | grep ipv6 BUT since return of the command still mention ipv6 after "disabling ipv6" as per I am no longer sure the command is of any use for veryfying whether disabling of IPv6 was successful. Hence I'll refrain from any further comments until I test it properly, with linux vs windows cross-testing. Sorry for the confusion! :/ Perhaps the website is better for the purpose. I assume a 0/10 score means one has IPv6 disabled :)

Bucic gravatar imageBucic ( 2013-03-28 14:05:16 -0500 )edit

answered 2013-08-28 01:49:13 -0500

princevj gravatar image

updated 2013-08-28 01:50:23 -0500

First of all try clearing cookies,browser history and cache,avoid running electronic devices at once,upgrade your modem or router to a newer model and have a periodic check in your modem ventilation, or do you use P2P (Peer to Peer) file sharing programs? If so then try turning the file sharing program off, as file sharing programs use up allot of bandwidth some broadband providers limit the speed you can use the internet if you are using file sharing programs.

If you turn off the file sharing program your broadband speed goes back to normal .

I faced the same problem ,after doing this i checked my speed from apparently my internet speed is faster than before. If these doesn't apply ,there is a chance you may have a virus on your computer. A computer virus is likely to not just slow your broadband and Internet down but your computer too.

edit flag offensive delete link more

answered 2013-08-06 09:33:59 -0500

Often, perceived slowness and inaccessible sites can be caused by an ill performing DNS server. Try using a free and known good service instead:

echo "nameserver">/etc/resolv.conf

If this helps, you can change the setting permanently in nm-connection-editor

edit flag offensive delete link more

Question Tools



Asked: 2013-03-25 10:09:28 -0500

Seen: 4,693 times

Last updated: Feb 20 '14