Ask Your Question
0

bumblebee error on fedora 18

asked 2013-03-25 06:32:32 -0600

goiha gravatar image

updated 2013-08-26 12:31:15 -0600

ryanlerch gravatar image

I install bumblebee step-by-step in fedora wiki. I run optirun glxspheres -info and get error:

    [ 1445.849940] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 1445.850085] [ERROR]Could not connect to bumblebee daemon - is it running?

$ systemctl | grep bumblebee
bumblebee-nvidia.service  loaded failed     failed       Compiling NVidia Driver
bumblebeed.service        loaded activating auto-restart Bumblebee C Daemon
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-29 05:59:38 -0600

crabman gravatar image

updated 2013-05-29 06:27:45 -0600

I have the same problem. I installed bumblebee-nvidia on my lenovo y570.

bash-4.2$ lspci -vnn | grep '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 555M] [10de:0deb] (rev a1) (prog-if 00 [VGA controller])

This is how I fixed it: I ran

sudo bumblebee-nvidia --debug

It reported

ERROR: Installation has failed.  Please see the file
   '/var/log/nvidia-installer.log' for details.

So I checked

cat /var/log/nvidia-installer.log

And I found

-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> The CC version check failed:

Could not compile 'gcc-version-check.c'.  Please be  sure you have your Linux distribution's gcc  and libc development packages installed.

So a little googling told me that I needed to install

sudo yum install glibc-devel

And after that it worked.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-25 06:32:32 -0600

Seen: 7,001 times

Last updated: Aug 26 '13