Ask Your Question
1

How to setup No-ip on Fedora?

asked 2013-03-21 17:58:31 -0500

Jmlevick gravatar image

updated 2013-03-26 02:20:08 -0500

Hello,

I want to setup a small Home Server using Fedora 17 (32 Bit) and No-ip because I have a Dynamic IP adress,

This is what am I doing:

1) I create a Host on No-ip:

image description

2) I setup No-ip on my fedora box:

su -
yum install noip
noip2 -C
chkconfig noip --add
chkconfig --levels 35 noip on

NOTE: My no-ip config file it's located at: /etc/no-ip2.conf

Reboot and verify it is running:

su -
service noip status
chkconfig --list | grep noip
host myserver.servebeer.com

(it actually points to my public IP adress)

3) Open Ports on the fedora's firewall:

image description

image description

4) Unlock No-IP on iptables:

su -
iptables -A INPUT -s dynupdate.no-ip.com -p tcp --sport 8243 -j ACCEPT
iptables -A OUTPUT -d dynupdate.no-ip.com -p tcp --dport 8243 -j ACCEPT
service iptables stop
service iptables start
service noip stop
service noip start
service noip status

5) Port Fowarding on the router:

image description

(I get the private IP adress from ifconfig)

6) Verify with Zenmap, Telnet & Ping

image description

NOTE: Here we have an interesting situation: Only the 80 TCP port seems to be open, the other two (111, 8243) are closed, even when they are unlocked on the firewall and fowarded on the router.

image description

PING fails, but as far as I know this is kinda normal right? 'cause ping isn't a DNS test mechanism... Correct me if I'm wrong please:

image description

Additional info:

I have an Apache/PHP setup, so if I go to http://127.0.0.1/test.php I see my test.php page, but if I go to http://myserver.servebeer.com or http://myserver.servebeer.com/test.php I can't see anything, the browser just tries and tries and then throws an error...

P.S. SELinux is fully Disabled

What am I doing wrong? Please Help me!

Have a nice day.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-26 18:03:09 -0500

ngoguen gravatar image

Hello,

The settings you provided appear to be correct. Accept I noticed you used port 8243 for the DUC when the DUC uses port 80 and 8245. You may want to correct that; however, as long as you are not blocking outbound traffic, this should not be an issue.

It's possible your router has trouble going out and back in on the same hostname, essentially creating a loop. If this is the case when you are at the location of the server you will need to use the localhost or the internal ip address of your server. When you are outside the server's network you could use http://myserver.servebeer.com/test.php.

No-IP Support will be glad to assist you can you can open a support ticket

-Natalie Online Marketing Manager No-IP www.noip.com

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-21 17:58:31 -0500

Seen: 7,432 times

Last updated: Mar 26 '13