Ask Your Question
0

public apache server

asked 2013-03-17 23:39:38 -0500

ZibZab gravatar image

I'm trying to setup apache to allow people to access my home server by entering my i.p address into their browser. I obviously haven't had any success.

I've enabled http and port 80 and 8080 under the firewall utility for fedora and set httpd to listen to port 8080 just in case my isp disabled 80. I've also turned off my routers firewall capabilities and disabled selinux.

Is there anything else I should enable in the firewall program and is there anything else I'm missing?

edit retag flag offensive close merge delete

Comments

Are you using NAT?

epawp gravatar imageepawp ( 2013-03-18 08:26:04 -0500 )edit

the only nat options my router has is port forwarding which doesn't have any data.

ZibZab gravatar imageZibZab ( 2013-03-19 02:29:38 -0500 )edit

I've enabled port 80 in my routers nat config and set it to match my assigned ip of 192.168.0.48 and rebooted my router. Nothing has changed. Any ideas at all?

ZibZab gravatar imageZibZab ( 2013-03-20 03:20:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-19 02:49:37 -0500

FranciscoD_ gravatar image
  1. Enable httpd
  2. Open ports in firewall

I'd suggest you try accessing your server from another system within the local network. If it works, the issue is a router set up.

Disabling selinux is not required. In fact, if you're opening your machine to access from the internet, I'd recommend you keep it on.

More information on how you're testing your configuration will be helpful too. Does it have a static IP? How are you finding the IP? NAT must be set up correctly (like @epawp has hinted) to make the machine accessible from the internet and not just other machines on the local network.

edit flag offensive delete link more

Comments

As I've stated http is enabled along with ports 80 and 8080, so which ports are you talking about with your #2?

I've switched selinux to permissive.

There is no static IP. I'm finding the ip by asking google? What do you meant NAT must be set up correctly?

Your answer is too vague for me to mark it as a solution or even vote it up.

ZibZab gravatar imageZibZab ( 2013-03-19 04:05:55 -0500 )edit

Question Tools

Stats

Asked: 2013-03-17 23:39:38 -0500

Seen: 549 times

Last updated: Mar 19 '13