Ask Your Question
0

.Xmodmap file not loading on startup

asked 2013-03-09 21:54:10 -0500

ttm gravatar image

updated 2014-04-11 16:38:24 -0500

remjg gravatar image

Sorry, Linux noob here.

I recently installed Fedora 18 (currently using gdm with Cinnamon), and I have an .Xmodmap file that I want to be loaded upon login. It's not working. Here's what I tried:

  • I put the file in ~/.Xmodmap, but it doesn't get automatically loaded.
  • I tried adding xmodmap ~/.Xmodmap to gnome-session-properties, but it doesn't get automatically loaded
  • I tried adding an xmodmap.desktop file containing that line to ~/.config/autostart but it doesn't get automatically loaded.
  • I stumbled upon a file called /etc/X11/Xmodmap and tried adding my mappings to the end of that, but they don't get automatically loaded.
  • I tried adding a script containing xmodmap /home/tony/.Xmodmap to /etc/X11/xinit/xinitrc.d but it doesn't run.
  • I tried moving the script to /etc/gdm/PostLogin/ but it still doesn't run.
  • I tried moving the script to /etc/gdm/PreSession/ but it still doesn't run.

I tried all of these things in both Cinnamon and GNOME. I'm out of things to try. What do I do?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-12 10:14:34 -0500

ThomasMcA gravatar image

updated 2013-03-16 20:38:31 -0500

Perhaps it runs, but fails with an error. Does it work when you run it manually from a console? Also, check the log (/var/log/messages) for errors.

Edit: Seems to be a known bug.

edit flag offensive delete link more

Comments

It runs correctly (I put it in my .bashrc for now). There are no relevant errors.

ttm gravatar imagettm ( 2013-03-16 17:24:40 -0500 )edit

Question Tools

Stats

Asked: 2013-03-09 21:54:10 -0500

Seen: 3,496 times

Last updated: Mar 16 '13