Ask Your Question
0

how to install tftp-server on f18

asked 2013-03-09 02:28:09 -0500

yurij gravatar image

I tried to install tftp-server by step-by-step, and at point of #chkconfig tftp on i get

The unit files have no [Install] section. They are not meant to be enabled using systemctl

I guess may be i missed some important part in /usr/lib/systemd/system/tftp.service file. Something like

[Install]
#some directiives here

When i try to start service tfp I always get

localhost.localdomain systemd[1]: Starting Tftp Server...
-- Subject: Unit tftp.service has begun with start-up
-- Defined-By: systemd

-- Unit tftp.service has begun starting up.
08 18:39:05 localhost.localdomain systemd[1]: tftp.service failed to run 'start' task: Invalid argument
08 18:39:05 localhost.localdomain systemd[1]: Failed to start Tftp Server.
-- Subject: Unit tftp.service has failed
-- Defined-By: systemd

-- Unit tftp.service has failed.
-- 
-- The result is failed.

How could i correct the situation?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-10 18:27:19 -0500

updated 2013-03-10 18:28:11 -0500

You might be using tftp for different purposes, but the network installation section of the Installation Guide covers setting up a tftp server:

https://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/s1-netboot-pxe-config.html

edit flag offensive delete link more
0

answered 2013-03-09 16:53:57 -0500

jmt gravatar image

You don't need to start the tftp service. It will be started by xinetd when needed, that is when a client tries to connect to port 69.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-09 02:28:09 -0500

Seen: 5,892 times

Last updated: Mar 10 '13