Ask Your Question
2

which F18 services can be disabled to speedup boot?

asked 2013-03-06 15:46:21 -0500

r0polach gravatar image

updated 2014-09-28 13:12:41 -0500

mether gravatar image

On my system F18 boot is taking too long: 24.5 sec. In comparison, e.g. old Ubuntu 10.04 was about 10x faster. I believe that systemd architecture is superior to Ubuntu's Upstart, so the problem must be in services... But the question is which services can be safely disabled? And disabling which services would help most?

Here is output of

* systemd-analyze

  Startup finished in 1533ms (kernel) + 2514ms (initrd) + 20422ms (userspace) = 24470ms

* systemd-analyze blame

  4403ms firewalld.service
  3750ms systemd-udev-settle.service
  2903ms fedora-storage-init.service
  2802ms accounts-daemon.service
  2107ms chronyd.service
  1755ms iscsid.service
  1634ms NetworkManager.service
  1422ms restorecond.service
  1342ms gdm.service
  1307ms fedora-loadmodules.service
  1198ms ksmtuned.service
  1063ms polkit.service
  1054ms systemd-modules-load.service
  1035ms dev-mqueue.mount
  1026ms systemd-udev-trigger.service
  1024ms dev-hugepages.mount
  1008ms sys-kernel-debug.mount
   973ms tmp.mount
   972ms systemd-udevd.service
   934ms systemd-remount-fs.service
   739ms systemd-vconsole-setup.service
   680ms mcelog.service
   651ms avahi-daemon.service
   648ms fedora-storage-init-late.service
   641ms lvm2-monitor.service
   632ms irqbalance.service
   566ms systemd-sysctl.service
   549ms fedora-readonly.service
   507ms systemd-logind.service
   494ms rtkit-daemon.service
   449ms systemd-tmpfiles-setup.service
   410ms abrt-ccpp.service
   315ms auditd.service
   256ms systemd-user-sessions.service
   182ms rc-local.service
   164ms sm-client.service
   142ms iscsi.service
   134ms media-_Data.mount
   132ms abrt-vmcore.service
   126ms udisks2.service
   122ms colord.service
   115ms systemd-readahead-replay.service
   101ms systemd-readahead-collect.service
    92ms sendmail.service
    79ms ksm.service
    36ms livesys.service
    28ms rpcbind.service
    27ms livesys-late.service
    19ms bluetooth.service
     9ms upower.service
     3ms sys-fs-fuse-connections.mount
     2ms sys-kernel-config.mount
  • systemd-analyze plot

    h t t p : // artwine.wz.cz/m/boot-graph1.png

    h t t p : // artwine.wz.cz/m/boot-graph2.png

edit retag flag offensive close merge delete

Comments

I have tried

for s in fedora-storage-init fedora-storage-init-late systemd-udev-settle plymouth-halt plymouth-kexec plymouth-poweroff plymouth-quit plymouth-quit-wait plymouth-read-write plymouth-reboot plymouth-start plymouth-switch-root lvm2-monitor mdmonitor fcoe atd abrt-ccpp abrtd abrt-oops abrt-vmcore abrt-xorg auditd avahi-daemon bluetooth fedora-configure fedora-loadmodules fedora-readonly ip6tables iptables; do systemctl mask $s.service; done

but boot times improved from 24.5s only to 23.5s. I expected more. Still not comparable to Ubuntu's cca 3s :(

r0polach gravatar imager0polach ( 2013-03-09 16:36:28 -0500 )edit
1

I have read

h t t p : //freedesktop.org/wiki/Software/systemd/Optimizations

h t t p : //www.harald-hoyer.de/personal/blog/fedora-17-boot-optimization-from-15-to-3-seconds

h t t p: //worldofgnome.org/speed-up-gnome-in-systemd-distributions/

h t t p : //www.ihackforfun.eu/index.php?title=improve-security-by-removing-services&more=1&c=1&tb=1&pb=1

h t t p s : //ask.fedoraproject.org/question/7012/which-service-is-doing-what/

but I still get no idea what I should do really speed up the boot process to less than 23.5s

r0polach gravatar imager0polach ( 2013-03-09 16:43:30 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-03-06 16:03:10 -0500

Guiri gravatar image

updated 2013-03-06 16:03:30 -0500

Hi, you may find this blog post useful... Google "fedora-17-boot-optimization systemd". I can't post links on answers yet.

But use common sense. For example, I disabled Bluetooth and ip6tables because I don't have a Bluetooth radio or IPv6 networking.

edit flag offensive delete link more

Comments

1

Thanks. I didn't have enough Karma at the time, but that's the correct link.

Guiri gravatar imageGuiri ( 2013-03-06 17:25:30 -0500 )edit

I have tried

for s in fedora-storage-init fedora-storage-init-late systemd-udev-settle plymouth-halt plymouth-kexec plymouth-poweroff plymouth-quit plymouth-quit-wait plymouth-read-write plymouth-reboot plymouth-start plymouth-switch-root lvm2-monitor mdmonitor fcoe atd abrt-ccpp abrtd abrt-oops abrt-vmcore abrt-xorg auditd avahi-daemon bluetooth fedora-configure fedora-loadmodules fedora-readonly ip6tables iptables; do systemctl mask $s.service; done

but boot times improved from 24.5s only to 23.5s. I expected more. Still not comparable to Ubuntu's cca 3s :(

r0polach gravatar imager0polach ( 2013-03-09 16:12:49 -0500 )edit

I have read

h t t p : //freedesktop.org/wiki/Software/systemd/Optimizations

h t t p : //www.harald-hoyer.de/personal/blog/fedora-17-boot-optimization-from-15-to-3-seconds

h t t p: //worldofgnome.org/speed-up-gnome-in-systemd-distributions/

h t t p : //www.ihackforfun.eu/index.php?title=improve-security-by-removing-services&more=1&c=1&tb=1&pb=1

h t t p s : //ask.fedoraproject.org/question/7012/which-service-is-doing-what/

but I still get no idea what I should do really speed up the boot process

r0polach gravatar imager0polach ( 2013-03-09 16:14:34 -0500 )edit
0

answered 2013-03-06 20:39:24 -0500

ThomasMcA gravatar image

The following script disables some unused services on my laptop. The # lines are just comments that describe what I'm disabling and why. The single line at the bottom disables them.

WARNING: The script below may disable services that are important on your computer. The script worked for me, but you'll probably need to modify it to fit your needs.

I don't use selinux or lvm, so a couple of them disable secondary services related to those functions. A couple of them are also specific to servers, but I didn't bother to remove them since they aren't running anyway.

You have been warned.

Here is what I disabled:

# apmd - old power manager system
# avahi-daemon - auto-detects new network devices like printers
# auditd - why audit who did what when there's only one user?
# atd is for at command
# bluetooth
# chargen is for testing
# fcoe - fibre channel over ethernet
# irda - infrared
# iscsi & iscsid - only if you have iscsi devices
# isdn
# kdump - kernel dump analyzer
# livesys - only needed on LiveCD
# livesys-late - only needed on LiveCD
# lldpad - an fcoe component
# lvm2-monitor - LVM disks
# mcstrans - selinux stuff
# mdmonitor - for RAID
# mdmonitor-takeover - for RAID
# netfs - only for Linux Network File System
# nfslock - only for Linux Network File System
# pcscd - for smartcards
# portmap - only for Linux Network File System
# readahead_early & readahead_later - performance services that don't work
# restorecond - selinux stuff
# routed - this isn't a router
# rpcgssd - only for Linux Network File System
# rpcidmapd - only for Linux Network File System
# sendmail is buggy - use postfix instead
# setroubleshoot - selinux stuff
# snmpd - for monitoring via snmp

The command below disables all of the above services. It is one long command. If it wraps on your screen, you must remove the line break in the pasted text before it will work.

for s in apmd atd auditd avahi-daemon bluetooth chargen fcoe ip6tables irda iscsi iscsid isdn kdump livesys livesys-late lldpad lvm2-monitor mcstrans mdmonitor mdmonitor-takeover netfs nfslock pcscd portmap readahead_early readahead_later restorecond rpcgssd rpcidmapd routed sendmail setroubleshoot sm-client snmpd; do echo $s; systemctl disable $s.service; done
edit flag offensive delete link more

Comments

I have tried disable all services you mentioned (except restorecond) and disabled several others more (fedora-storage-init fedora-storage-init-late systemd-udev-settle plymouth-halt plymouth-kexec plymouth-poweroff plymouth-quit plymouth-quit-wait plymouth-read-write plymouth-reboot plymouth-start plymouth-switch-root abrt-ccpp abrtd abrt-oops abrt-vmcore abrt-xorg fedora-configure fedora-loadmodules fedora-readonly ip6tables iptables)

...but boot time improves from 24.5 only to 23.5. I also tried masking services instead of removing (as recomended elsewhere) but I got still the same result

r0polach gravatar imager0polach ( 2013-03-07 14:52:07 -0500 )edit

Can you post a new blame? I'm curious to see what's causing the issue since you've disabled some major ones (from your output) such as iscsi and iscsid.

Guiri gravatar imageGuiri ( 2013-03-14 20:45:21 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2013-03-06 15:46:21 -0500

Seen: 12,283 times

Last updated: Mar 07 '13