Ask Your Question
1

how can I change boot menu screen resolution in grub2?

asked 2013-03-02 12:30:39 -0500

metin gravatar image

updated 2014-02-01 05:05:36 -0500

I have installed Fedora-gnome3 spin. Fedora is a very solid distro with great software repositories. But one thing that is annoying to me is that the grub2 boot menu resolution is really low and everything looks huge. How can I correct that?

Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-31 08:14:08 -0500

While Fedora's variation on the grub2 boot manager is a little different, and perhaps more constrictive, than in other Linux distributions, the user is not confined to a single video resolution in the boot menu. Keep in mind that your system's configuration/hardware/specs, etc.. have to support the framebuffer resolution of choice;

Briefly, to answer your question, edit the file /etc/default/grub and change/uncomment or add the following lines to read:

GRUB_GFXMODE='1280x1024x32'
GRUB_GFXPAYLOAD=keep

as a precaution, you can add multiple values separated by a semicolon; as well as the "auto" value if all else fails:

GRUB_GFXMODE='1280x800x32;1280x800x24;1280x768x32;1280x768x24;1280x1024x32;auto'

You can also see this

edit flag offensive delete link more

Comments

1

This is the way to do it, but you're adding to your boot time. If the system doesn't have to load video drivers, it will boot much faster.

randomuser gravatar imagerandomuser ( 2014-02-04 23:41:36 -0500 )edit

So, I did this in CentOS 7 with Grub2, and the OS keeps reverting to the tiny terminal window. I don't have any X11 libraries installed, or running.

Predatorian3 gravatar imagePredatorian3 ( 2016-08-29 09:23:21 -0500 )edit

Question Tools

Stats

Asked: 2013-03-02 12:30:39 -0500

Seen: 10,588 times

Last updated: Jan 31 '14