Ask Your Question
0

Wireless driver not started automatically

asked 2013-03-01 21:42:49 -0500

yanglifu90 gravatar image

I have to run modprobe b43 every time in order to connect to wi-fi, what is the problem?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-02 12:36:37 -0500

yanglifu90 gravatar image

I just removed kmod-wl and it worked, looks like they are incompatible.

edit flag offensive delete link more
0

answered 2014-09-14 14:10:29 -0500

waldyd gravatar image

Just comment out the appropriate line (blacklist b43) at:

[root@localhost ~]# cat /usr/lib/modprobe.d/broadcom-wl-blacklist.conf
# modules blacklisted for broadcom-wl
blacklist ssb
blacklist bcma
blacklist b43
blacklist brcmsmac
blacklist brcmfmac
blacklist b43-pci-bridge

uninstall kmod-wl is a little bit drastic.

edit flag offensive delete link more
0

answered 2013-03-02 00:04:08 -0500

FranciscoD_ gravatar image

What method have you used to set up wireless? If you used the b43-fwcutter method, you need to run the command at every boot.

Here's how to do it with systemd: How to run scripts on boot with systemd.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-01 21:42:49 -0500

Seen: 804 times

Last updated: Sep 14 '14