Ask Your Question

Broadcom Inc. and subsidiaries BCM43142 fedora 29, no wifi

asked 2019-04-18 21:43:33 -0500

Jocsan gravatar image

updated 2019-04-21 18:48:47 -0500

Yes, same old story Broadcom is surprisingly not working with Fedora 29, I tried this:

sudo dnf install -y
sudo dnf install -y broadcom-wl kernel-devel
sudo akmods --force --kernel 'uname -r' --a kmod wl

And I get this back:

Could not find files needed to compile modules for uname -r
Are the development files for kernel uname -r or the appropriate kernel-devel package installed?

Any idea on how to solve this, I'm working on fedora 29, a quick google search says that it might be that the driver is not supported for the version of kernel I'm using.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-04-23 21:09:01 -0500

davidva gravatar image

In UnitedRPMs is easy...

Enable the repository

Guide official here

Install the driver...

dnf remove broadcom-wl kmod-wl
dnf -y install broadcom-wl-dkms


edit flag offensive delete link more


So I was able to do the dnf -y install broadcom-wl-dkms and it completes succesfully, fo I reboot afterwards? Or should it work from the get go?

Jocsan gravatar imageJocsan ( 2019-04-25 21:36:54 -0500 )edit

@Jocsan . You don't need reboot (theoretically)... The module is loaded in the installation :)

davidva gravatar imagedavidva ( 2019-04-26 00:09:03 -0500 )edit

answered 2019-04-21 17:44:41 -0500

richard378 gravatar image

updated 2019-04-21 17:48:15 -0500

install kernel header files. sudo dnf -y install kernel-devel kernel-headers Also sudo dnf install kmod-wl then reboot

edit flag offensive delete link more


I've already installed kernel-devel and kernel-headers, but maybe I don't have the kmod-wl, I'll try that, thanks.

Jocsan gravatar imageJocsan ( 2019-04-21 18:50:09 -0500 )edit

Question Tools

1 follower


Asked: 2019-04-18 21:43:33 -0500

Seen: 1,514 times

Last updated: Apr 23 '19