Ask Your Question

Grub does not acknowledge changes to grub.cfg

asked 2019-03-31 19:01:44 -0500

MoshyBox gravatar image

updated 2019-03-31 19:12:18 -0500

My grub.cfg changes in /boot/efi/EFI/fedora do not seem to affect my grub boot menu entries. I tried reinstalling grub via dnf reinstall grub2-efi shim to no avail. Interestingly, when I print the contents of grub.cfg from the grub console it does not show the changes I made when booted into Fedora. For example, the entry for the 5.0 kernel is clearly present in the config file when logged into Fedora, but that entry does not show up when accessing the file through the grub console.

Note: I do not have any graphical access to the OS at the moment because I only installed NVIDIA drivers after experiencing this issue (I didn't realise nouveau didn't support the latest card series before upgrading).

Thanks in advance!

edit retag flag offensive close merge delete


... because you are not booting with secure boot enabled ..

cp /boot/efi/EFi/fedora/grub.cfg /boot/grub2/

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-01 04:40:44 -0500 )edit

Hi! That didn't seem to change anything. Although, should /boot/grub2/ be important in this case? Based on the wiki, wouldn't the config in the efi directory be used instead?

MoshyBox gravatar imageMoshyBox ( 2019-04-01 12:38:53 -0500 )edit

that depends, if the symlink in /boot/grub2/ is set correctly. But if everything would be ok, you won't have problems, don't you agree? ;)

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-01 15:59:54 -0500 )edit

(because i have it running, did you ever had a second boot partition?)

rdtcustomercare gravatar imagerdtcustomercare ( 2019-04-01 16:00:31 -0500 )edit

I don't have any other boot partitions on the drive I am trying to boot from. However, it might be possible that it's booting from my second drive which I recently cloned to. I'm not sure how that would happen (I did manually boot to drive 0 from uefi menu) but I'll try pulling it out and seeing if that changes anything.

MoshyBox gravatar imageMoshyBox ( 2019-04-01 16:49:00 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2019-04-06 16:12:42 -0500

alamahant gravatar image

After making changes to /etc/default/grub you have to run grub2-mkconfig -o /boot/efi?EFI/fedora/grub.cfg to generate new grub.cfg file.This will also run os-prober and automatically create entries in grub.cfg. Also you dont normally need to edit grub.cfg manually unless you want to do some kind of special tweak. This file is generated by entries in /etc/default/grub and /etc/grub.d/<files>. when you run grub2-mkconfig command.

edit flag offensive delete link more


Hi! That's part of the problem I'm having. Regardless of how I change the file (even when generated via mkconfig), the menu does not change. I suspect it's something to do with my previous comment on the question's thread, but I've been too busy all week to get a chance at that machine. I will hopefully have a go later today.

MoshyBox gravatar imageMoshyBox ( 2019-04-07 11:13:54 -0500 )edit

answered 2019-04-10 11:21:05 -0500

MoshyBox gravatar image

It turns out that my bios was having trouble booting into the right boot partition. I recently cloned my Windows partition (along with boot) onto another SSD with Samsung's migration software. Apparently the final step in the procedure is to swap the new drive into the SATA port of the original. It turns out that if you don't follow through with this step, the cloned boot partition looks identical to the original, despite being on different SATA ports. My BIOS was not picking up the difference and so always booted using the grub.cfg found in the cloned drive.

TL;DR: I had a messy drive configuration which had nothing to do with actual Fedora/GRUB issues.

edit flag offensive delete link more



That's what @rdtcustomercare suggested and that's why I offered way to verify, on which drive exactly the grub installation you're in right now resides, and which exactly config file it uses right now.

Glad you've figured it out! ;-)

Night Romantic gravatar imageNight Romantic ( 2019-04-11 02:54:00 -0500 )edit

Yep, his/her suggestion was very helpful in identifying the final issue. I must have missed your offer, and still don't see it anywhere but I do appreciate your support.

If someone could mark my answer as the final/correct one, that would be great!

edit: I just now have discovered that I was supposed to click "see more comments" to see further replies... It looked the same as "add comment" to me this whole time. Apologies to everyone who tried to help but didn't have me respond. I do appreciate it!

MoshyBox gravatar imageMoshyBox ( 2019-04-11 11:46:29 -0500 )edit

It says to me that moderator OR the question author can mark the answer as correct one. Have you tried marking it yourself? )

Night Romantic gravatar imageNight Romantic ( 2019-04-12 02:33:03 -0500 )edit

Question Tools



Asked: 2019-03-31 19:00:25 -0500

Seen: 144 times

Last updated: Apr 10 '19