Ask Your Question
0

How can I permanently turn off DPMS ?

asked 2019-03-30 05:14:53 -0500

I have an issue when trying to wake-up my monitors after locking my screen. The monitors don't wake up if I immediately try to do so after locking. It only works after ~10mins.

After a lot of research I found a fix for this, to run xset -dpms.

I don't want to run this on every login. Is there a way to make it permanent ?


System:    Host: firefly Kernel: 5.0.3-200.fc29.x86_64 x86_64 bits: 64 Desktop: Gnome 3.30.2
           Distro: Fedora release 29 (Twenty Nine)
Machine:   Type: Laptop System: LENOVO product: 20HH001RMZ v: ThinkPad P51 serial: <root required>
           Mobo: LENOVO model: 20HH001RMZ v: SDK0J40697 WIN serial: <root required> UEFI: LENOVO v: N1UET40W (1.14 )
           date: 09/28/2017
Graphics:  Device-1: NVIDIA GM206GLM [Quadro M2200 Mobile] driver: nvidia v: 418.56
           Display: x11 server: Fedora Project X.org 1.20.4 driver: nvidia resolution: 3840x2160~60Hz
           OpenGL: renderer: Quadro M2200/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56
edit retag flag offensive close merge delete

Comments

if you like to automate it, you can create a shell script and create a desktop file to call it in the ~/.config/autostart folder

Rabin gravatar imageRabin ( 2019-03-30 16:06:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-05 01:52:29 -0500

linux.alder gravatar image

It is an OLD methodology; but it still works.

Add command to /etc/rc.d/rc.local

systemctl enable rc-local

chmod +x /etc/rc.d/rc.local

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-03-30 05:14:53 -0500

Seen: 299 times

Last updated: Apr 05 '19