Ask Your Question

Fedora 29 not updating due to samba conflict

asked 2019-03-29 06:27:14 -0500

rvallel gravatar image

updated 2019-03-29 10:54:32 -0500


My updates are no longer taking place, when I try by hand with "dnf update" I get:

>Running transaction test
>The downloaded packages were saved in cache until the next successful transaction.
>You can remove cached packages by executing 'dnf clean packages'.
>Error: Transaction check error:
>  file /usr/lib64/samba/ from install of samba-libs-2:4.9.5-0.fc29.x86_64 conflicts with file >from package samba-client-libs-2:4.9.4-1.fc29.x86_64

It almost looks like samba is conflicting with itself.

Any idea what this is and how to solve it?

List of installed packages seems to show several versions at the same time,

$ sudo dnf list installed 'samba*' Installed Packages samba-client.x86_64 2:4.9.5-0.fc29 samba-client-libs.x86_64 2:4.9.4-1.fc29
samba-client-libs.x86_64 2:4.9.5-0.fc29 samba-common.noarch 2:4.9.4-1.fc29
samba-common.noarch 2:4.9.5-0.fc29
samba-common-libs.x86_64 2:4.9.4-1.fc29
samba-common-libs.x86_64 2:4.9.5-0.fc29
samba-libs.x86_64 2:4.9.4-1.fc29

$ sudo dnf check-update | grep samba samba-libs.x86_64 2:4.9.5-0.fc29 updates

edit retag flag offensive close merge delete


It's quite strange, I've updated samba* packages from 4.9.4-1 to 4.9.5-0 successfully on March 19. Without any conflicts, needless to say.

  1. You can try sudo dnf upgrade --skip-broken -- it should do what it can and skip all conflicting packages.

  2. Can you please post here output of sudo dnf list installed 'samba*' and sudo dnf check-update | grep samba? Question is, do you have samba-libs-2:4.9.5-0.fc29.x86_64 in the list of packages for update, or have you already installed the updates and something went wrong.

Night Romantic gravatar imageNight Romantic ( 2019-03-29 07:28:11 -0500 )edit

I think, most probably, something that went wrong triggered this issue.

rvallel gravatar imagervallel ( 2019-03-29 10:55:23 -0500 )edit

I've had similar situation once (with some other packages) when my computer hang up during the update process. I was able to delete older versions of "doubled up" packages to resolve the issue -- commands to do it with dnf and rpm by @villykruse are in the answer.

Night Romantic gravatar imageNight Romantic ( 2019-04-01 01:56:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-03-29 11:11:58 -0500

Night Romantic gravatar image

updated 2019-03-29 11:13:18 -0500

@rvallel, I think that's because something went wrong during the update. As a result you've got two versions of some packages left on the system, and that's the reason of conflicts dnf's telling you about.

Here's the list as it is on my computer

You should try to remove older versions manually:

sudo dnf remove samba-client-libs-2:4.9.4-1.fc29.x86_64 samba-common-2:4.9.4-1.fc29.noarch samba-common-libs-2:4.9.4-1.fc29.x86_64

When dnf asks for confirmation, verify, that it wants to remove these three packages only and nothing else. If if wants to remove anything else -- say "No".

If you're lucky and it removes just these three packages -- then try sudo dnf upgrade once more.

Please write here the results.

edit flag offensive delete link more


Or run (as root or with sudo) rpm --erase samba-client-libs.x86_64 2:4.9.4-1.fc29 samba-common-libs.x86_64 2:4.9.4-1.fc29 samba-common.noarch 2:4.9.4-1.fc29 samba-libs.x86_64 2:4.9.4-1.fc29.

Also run dnf check to check if there are other problems.

villykruse gravatar imagevillykruse ( 2019-03-29 12:19:16 -0500 )edit

Question Tools

1 follower


Asked: 2019-03-29 06:27:14 -0500

Seen: 92 times

Last updated: Mar 29 '19