Ask Your Question

40 second delay before keyboard turns on during boot-up decryption phase

asked 2019-03-11 05:06:01 -0500

Aeyoun gravatar image

I’ve enabled encryption of my home and root partitions in Fedora 29. This works great, but it has introduced a large delay in my boot process. The system quickly boots up to the point where I need to enter my password. However, the keyboard doesn’t work for another 40 seconds after that. I’ve got a backlit keyboard and the lights don’t come up before some 30–40 seconds after the password prompt screen does.

I’ve tried using a different keyboard and I’ve tried using different USB ports on my system. This doesn’t make any difference at all.

Any ideas on what might be causing this? or how I can troubleshoot it?

edit retag flag offensive close merge delete


please consult the output of "dmesg" . You hardware seems to be found late. Could be a udev problem or kernel-mod problem.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-12 10:24:02 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-03-11 12:42:49 -0500

Kostya Vasilyev gravatar image

Maybe insufficient entropy?

I would try installing this package

Regarding troubleshooting - have you checked dmesg and system logs?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2019-03-11 05:06:01 -0500

Seen: 71 times

Last updated: Mar 11 '19