Ask Your Question

FEDORA 29 Problem with DNS resolving

asked 2019-02-27 17:06:25 -0500

dimitriszz gravatar image

Since the first day I installed Fedora 29 I experience problems with DNS resolving. Today it stopped working completely. The network seems not to work properly, and I cannot update the installed applications. I tried to change the DNS servers in Network - Wired and then I run the command sudo systemctl restart NetworkManager and edited the file /etc/resolv.conf Unfortunately, the result was catastrophic for my Network settings! One thing I suspect happens is that ISP blocks my DNS resolver ( However, until yesterday that setting was working OK and the response was excellent. How can I resolve my issues?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2019-02-28 04:17:57 -0500

Kostya Vasilyev gravatar image

updated 2019-02-28 04:19:50 -0500

To see if your network provider is blocking Google's DNS you can try this :

dig @

The at sign means send the query to the specified DNS server bypassing system config.

Second, Network Manager will manage /etc/resolv.conf for you so your edits will not persist past reboot or NM restart.

Third, if is not blocked, you may want to add it in your connection properties in network manager (and it will automatically end up in resolv.conf).

If it is blocked meaning your ISP wants you to use their own DNS then you probably have little choice... The ISP's support should be able to tell you what their DNS server is (maybe they send it over DHCP by the way).

The above assumes that your system is connected at all and it's just DNS which is an issue. To check you can try to ping the default gateway as a test.

edit flag offensive delete link more


BTW.. there is a way to circumvent dns blocks with ssh :) https://marius.bloggt-in-braunschweig... or use a vpn provider

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 10:39:56 -0500 )edit

answered 2019-02-28 22:49:08 -0500

Dallas357 gravatar image

updated 2019-03-01 00:51:19 -0500

sideburns gravatar image

For some reason the default DNS wasn't working fine, changed it to as Raman Sailopal suggested and did a reboot

EDIT: Removed commercial link.

edit flag offensive delete link more


I edited the /etc/resolv.conf file and I put the DNS server first. The file now is as follows:

## Generated by NetworkManager
search home
##NOTE: the libc resolver may not support more than 3 nameservers
## The nameservers listed below may not be recognized
nameserver 2a02:1800:100:41:1
nameserver 2a02:1800:100:41:2

For your information there is no link on this file, but when I reboot the machine the namesevers change positions: the goes after

dimitriszz gravatar imagedimitriszz ( 2019-03-01 16:46:01 -0500 )edit

answered 2019-02-28 15:24:04 -0500

dimitriszz gravatar image

Thank you guys for your replies. @Kostya: The dig command indeed is blocked. I confirmed that I can ping and ping the default gateway and another machine in the local network. I also can read my emails. However, I cannot reach other domains, and for many others, access is prolonged. I will check it with my ISP for resolving the problem. What worries me most is that the behavior is unpredictable, and the one day I cannot access at all while others the connection is lightning fast - I have a fast connection to the internet. @rdtcustomercare: I need a simple solution for normal access to the internet, and using tunneling introduces unnecessary complexity. On top of that, such a solution covers under the carpet the real issue. I'll be back to you with the solution in case my ISP resolves the problem, or for more help!

edit flag offensive delete link more


good luck with that. They do it on purpose, i.e. for blocking.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-01 05:23:30 -0500 )edit

Question Tools


Asked: 2019-02-27 17:06:25 -0500

Seen: 1,803 times

Last updated: Mar 01 '19