Ask Your Question
1

Fedora 29 settings/power how to specify hibernate instead of suspend?

asked 2019-02-27 07:07:01 -0500

The Evil One gravatar image

I want my computers to hibernate rather than suspend because I resent wasting electricity to keep the memory alive. However the Gnome Settings/Power screen only mentions SUSPEND. How do I activate hibernation after timeout rather than suspend.

Already hacve SWAP file system of 8Gib which is double memory size of 4GiB

edit retag flag offensive close merge delete

Comments

could be , that you need pass it to the kernel. As i'm compiling the kernel for surface pro touch devices, the process has a option to choose hibernate or sleep ( suspend ). But i'm not sure.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-27 07:53:50 -0500 )edit

Maybe I am asking the wrong question. I am assuming that "SUSPEND" means power saving by shutting down most but not all computer circuits leaving the RAM powered to maintain state and that "HIBERNATE" 'refers to shutting down all circuits saving the computer state on disk but perhaps SUSPEND as used on the power configuration screen means power saving switching off entirely saving state on disk if there is sufficient swap space available and otherwise leaving the memory drawing power???

The Evil One gravatar imageThe Evil One ( 2019-02-27 20:40:23 -0500 )edit

"suspend" => sleepmode => ram has power,display off, cpu off. "hibernate" => ram saved to disk, hw has power off, on poweron, system checks for hibernate signature and load back the ram image.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 10:57:28 -0500 )edit

Thankyou rdtcustomercare for your comments. I do not know what you mean by your 2nd one. What is the meaning of the right pointing arrows and to what is the exact meaning of the "suspend" in the beginning. Is it a sequence of GNOME settings screens or a sequence of commands entered into a terminal window?

Regards The Evil One.

The Evil One gravatar imageThe Evil One ( 2019-03-01 05:57:51 -0500 )edit

askbot removed the LineFeed between those lines and makes it hard to read now. "=>" means "means" ;)

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-01 07:38:14 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-03-02 12:30:59 -0500

ptrck4193 gravatar image

updated 2019-03-02 12:48:06 -0500

I'm presently using the LXDE spin which is an excellent low-resource desktop. So I am surprised to see HIBERNATE as an option when I select LOGOUT in the panel. HIBERNATE is not in the START menu by default for Windows 10 to save resource. The power usage in SLEEP is not extreme. As SU, enter "systemctl hibernate" [see systemd-hibernate.service (8)]. When to use what? SLEEP - out to lunch; HIBERNATE - overnight; BOOT - at least once a week. That will start an argument.

edit flag offensive delete link more
0

answered 2019-03-02 13:29:49 -0500

sixpack13 gravatar image

In my gnome setting there is an option to hibernate via power button.

maybe it's absent cause you don't have an hint to your swap partition in the kernel command line:

cat /etc/default/grub:

...
GRUB_CMDLINE_LINUX="resume=UUID=1fa013bc-d3e2-4382-8e92-df1e5c4d52dc rhgb quiet" 
...

UUID of your swap part. comes from command blkid.

you need to do

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

for a non-EFI or

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

for an EFI box if you changed /etc/default/grub !

I guess you need to reboot that the gnome power option apears - don't know -

gnome settings => Power => "When the Power Button is pressed" => selection box => hibernate

P.S. I mean I had read a notice that a box being in suspend do an automatic change being in hibernate after some time, sort-a "hybrid-suspend"..., - don't know where I have read that and what condition needs to met -

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-02-27 07:07:01 -0500

Seen: 678 times

Last updated: Mar 02 '19