Ask Your Question

How to set up windscribe VPN

asked 2019-02-23 09:07:56 -0500

Installed windscribe-cli VPN with instructions from logged in. Connected to VPN , done a which shows my internet provider, so i guess I have a dns leak. Am new to using a VPN. Installed on netrunner debian and all is OK there. have installed openvpn and plasma-nm-openvpn. So it changes my ip address but isn't using their servers for searches. Using fedora29 plasma. Any suggestions would greatly appreciated. Maybe someone can find something in this pkgbuild that might help. Maybe firewall needs setting.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-02-27 18:11:58 -0500

The problem is in their configuration for windscribe-cli which uses openvpn. You'll need to edit /etc/windscribe/client.ovpn add block-outside-dns after persist-tun. Then go into edit network connections and click on + and click on import vpn connection using the client.ovpn you edited. Don't use windscribe-cli until they fix it because it rewrites the client.ovpn file each time you connect.

edit flag offensive delete link more

answered 2019-02-25 05:17:50 -0500

updated 2019-02-25 05:20:40 -0500

(Root will be required)

check your "/etc/resolv.conf" and "route -n"

dns requests go to servers listed in resolv.conf . If these are reached directly without the vpn route, that is your problem.

To check this, look at "route -n". Your VPN should have setuped a default route to an interface opened by your vpn software. But if your default route points i.e. to your dsl/cable modem/router dns requests will take the direct way, instead of going throu the VPN gateway interface.

There is a chance, that your resolv.conf points to a local ip. Means you have a DNS Cache of some sort running i.e. "avahi-daemon" or "Bind" . Who they ask, you have to find out yourself. It's out of scope of this answere.

edit flag offensive delete link more

Question Tools



Asked: 2019-02-23 07:44:17 -0500

Seen: 792 times

Last updated: Feb 25 '19