Ask Your Question
0

Fedora 29 thinkpad T580 crashing/issues Please help :)

asked 2019-02-21 18:05:46 -0500

So I just recently bought a brand new thinkpad T580 and tried to put fedora 29 on it. At first the install went fine or so I thought and I was even able to use the laptop with fedora for like 3 hours the first night then I shut it off and went to bed. The next day I tried to use it again but this time It booted on, I logged in and the cursor moved super slow and nothing was working I couldn't even open settings. Then at the top I got a message saying "oops we're sorry, it looks like BOOT_IMAGE=/vmlinuz-4.20.8-200fc29 had crashed." Then it said there was an error and the error report opened up saying xorg-x11-drv-nouveau, system failure as well as system failure, system failure and vmlinuz-4.20.8-200.fc29.86_64 system failure. I restarted the computer and got it to install the updates so I thought maybe that would fix it but did not. I eventually tried to put opensuse on it and that seemed to work fine so I'm assuming it's not my laptop but I'm not 100 percent sure. I really want fedora on my laptop though so I tried to put fedora back on my laptop after using opensuse for a couple days and the same things happened. I'm not really sure how to troubleshoot the problem myself I've posted a thread on r/thinkpad and did some googleing but I have no idea what could be wrong. Any help would be greatly appreciated. If any of you have any ideas if it's fedora or my laptop please let me know. Thanks ahead of time for any help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-04-01 04:33:28 -0500

lindsaymacvean gravatar image

updated 2019-04-01 04:39:04 -0500

I had a similar problem on an MSI laptop. I read the following article that explained that fedora defaults to a driver that conflicts with Nvidia graphis cards (GeForce on mine). https://forum-en.msi.com/index.php?to...

Once the problem started happening the only way out for me was to press 'e' at the grub boot loader screen then add the options to GRUB_CMDLINE_LINUX= "d.driver.blacklist=nouveau,nvidia,nvidia_drm,nvidia_modeset,nvidia_uvm modprobe.blacklist=nouveau,nvidia,nvidia_drm,nvidia_modeset,nvidia_uvm"

Then once booted into the system it should speed up again, but you will need to make the change permanent by editing /etc/default/grub and adding the above variables in again.

sudo su
vi /etc/default/grub

Note: ':wq' writes and quits the vi editor.

edit flag offensive delete link more
0

answered 2019-03-05 11:46:16 -0500

I just stopped using fedora to many constant problems.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-02-21 18:05:46 -0500

Seen: 126 times

Last updated: Apr 01 '19