Ask Your Question

TP-Link Archer T9UH driver

asked 2019-01-14 13:59:24 -0500

RobinEll gravatar image

updated 2019-01-14 14:53:10 -0500

Hi, I have a TP-LINK Arhcer T9UH, I bought this as it said it was linux compatible on the box. however I have discovered when i went to download the driver it doesn't have a Fedora\Red hat driver.

I learnt that it uses the realtek 8814AU chip.

I downloaded the github source link text.

but when I Run make i get the following error.

[robin@robs-pc rtl8814au-master]$ sudo make -f Makefile 
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.19.13-300.fc29.x86_64/build M=/home/robin/Downloads/rtl8814au-master  modules
make[1]: *** /lib/modules/4.19.13-300.fc29.x86_64/build: No such file or directory.  Stop.

I followed the directories, and the build file is actually a link to /usr/src/kernels/4.19.13-300.fc29.x86_64. But the kernels directory is empty.

I tried installing the "C Development and Tools" grouplist but this didn't help.

any ideas?

UPDATE: ok i managed to install the kernel headers and build the driver, but now when i try to install driver with modprobe I get the permission not allowed message

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2019-01-19 03:32:01 -0500

updated 2019-01-19 04:13:18 -0500

I have the exact same adapter. You should use the drivers support by the aircrack-ng project which are kept up to date to support the latest kernal versions.

First make sure you install the Dynamic Kernal Module Support (dkms) package to recompile the drivers after each update. Otherwise the drivers will stop working when your kernal gets updated:

sudo dnf install dkms

Then follow these steps:

$ git clone -b v5.2.20
$ cd rtl*
$ sudo ./

To uninstall run sudo ./ from the same directoy where you installed, making sure the source is compiled.

If you want to install the driver without using the dkms package (not recommended) you can use make instead which still works:

$ make
$ sudo make install
edit flag offensive delete link more


Thanks that did the trick.

RobinEll gravatar imageRobinEll ( 2019-01-30 15:01:38 -0500 )edit

No problem. I forgot the mention you can use dkms status to list the packages managed by DKMS

SassyTheSasquatch91 gravatar imageSassyTheSasquatch91 ( 2019-01-31 00:35:25 -0500 )edit

answered 2019-02-24 02:16:20 -0500

To reiterate.

  1. sudo dnf install kernel-devel-4.20.10-200.fc29.x86_64
  2. sudo dnf install dkms-2.6.1-2.fc29.noarch
  3. Get this
  4. README inside rtl8812au-5.2.20/ and or sudo ./

and that should do it, I was stuck on the kernel headers not found hence i installed kernel-devel package.

All in all, the device functions within the F29 settings, my old pci-nic was running 6mbp/s now im at 140 mbp/s

edit flag offensive delete link more

Question Tools


Asked: 2019-01-14 13:59:24 -0500

Seen: 839 times

Last updated: Feb 24 '19