Ask Your Question

Finnish language missing from Libreoffice spellchecker

asked 2018-12-27 17:55:37 -0500

Janskis gravatar image

updated 2018-12-28 23:57:48 -0500


I have installed a ton of language packs for Finnish language, but still can't choose it for spell checking. Could someone please tell me what I'm missing here?

After new installation - with language packs installed afterwards - Finnish language is missing from the list of languages for spell checking in Libreoffice Writer ("Tools - Spelling").

Same result if Fedora29 installation language was "Finnish". In "Tools - Spelling" there are many different English dialects but no "Finnish".

I have: New installation Fedora29 Libreoffice Writer Language packs: libreoffice-voikko langpacks-fi glibc-langpack-fi autocorr-fi aspell-fi enchant-voikko libvoikko libvoikko-devel malaga-suomi-voikko mozvoikko voikko-tools

Can someone help please?

edit: Tried it on 3 different laptops. Hash and gpg signature are good. As comparison: it works on Debian9 with no problem.

edit retag flag offensive close merge delete


HI~ Janskis. plz, check system settings, and show me the result...and will be updated my answer!! have a nice day...

simmon gravatar imagesimmon ( 2018-12-27 22:35:17 -0500 )edit

Settings -> Region & Language: choosing "Finnish" changes the OS language, but no help in Libreoffice. Spell checking works in text editor, but not in Libreoffice.

Janskis gravatar imageJanskis ( 2018-12-28 01:49:51 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2019-02-13 05:05:20 -0500

timoaarnipuro gravatar image

I believe that the Fedora 29 packaging of libreoffice-voikko is broken. The python files under the extension should be located under a subdirectory called pythonpath.

You can verify this issue by exporting PYUNO_LOGLEVEL=ARGS to your environment and running soffice --writer from a console.

Also, you can work around the problem by moving the related .py files under the pythonpath directory (for example on x86_64 as root):

cd /usr/lib64/libreoffice/share/extensions/
mkdir pythonpath
mv pythonpath

I opened a bug to RedHat bugzilla as well:

edit flag offensive delete link more


Thank you so much!

Janskis gravatar imageJanskis ( 2019-04-26 04:23:58 -0500 )edit

answered 2018-12-27 22:33:41 -0500

updated 2018-12-28 11:11:02 -0500

My Libre shows normal behavior. Please check the setting value for setting and use.

For Finnish support and use, please install a stable version that is more faithful to the support than the latest bourbon.

I would like to make sure that the System Settings - Spell Checking - Custom Checklists dictionaries and options have been added to enable automatic language detection, and make sure that you have added the appropriate language to your regional settings.

Please check and make sure that relevant information is set. Spelling actions and settings are seen as working.

Application Launcher - System Settings - locale - Configure the Spell Checker
Check for enable ->
Enable  Automatic language detection (L)
Enable  Automatic spell checking enabled by default  (A)

I also use Libre. I can confirm that the relevant use is good, if there is insufficient language and language support libraries installed. Spell checking works well in related language tools. If the default settings and libraries are set well, it seems to work normally.

In addition to the above, I add .Voikko Download source archives

For additional information, I add the answers that villykruse answers in front of me.


Libraries and language related parts will be added if necessary. Check out the Finnish-related Libre document. I am looking for related materials. Please see here.

I checked the history, but it seems that the Finnish language does not support the latest Libre. I hope it helps you to use it soon. It is also a good idea to use a distribution that supports previous Libre. This article is up to this point.

edit flag offensive delete link more


Do you mean LIbreoffice -> Tools -> Options -> Language settings -> Languages? "User interface": English, "Locale settings": Finnish, "Default language for documents": Western Finnish Writing aids: Available language models: Hunspell-oikoluku, libhyphen-tavutus, Mythes-synonyymisanasto Voikko: nothing (blank page)

Janskis gravatar imageJanskis ( 2018-12-28 01:53:40 -0500 )edit

Libre tool - You can make detailed settings in spelling, and you can also check the relevant language support section by selecting the bottom selection O.Please let me know if you can see custom dictionaries and options?

simmon gravatar imagesimmon ( 2018-12-28 03:33:29 -0500 )edit
  1. Maybe you meant by "Libre tool" = "Libreoffice -> tools"? If not then dnf nor application launcher can't find it. Libreoffice -> tools -> spelling that's where "Finnish" should be (I suppose). But even if Finnish is OS, locale and input language and document language becomes automatically Finnish, there is no Finnish in Libreoffice -> tools -> spelling.
  2. In my Application launcher -> settings there is no "locale". The one and only related to language is: Region & language which has 1. Language 2. Formats 3. Input sources. Even if all these are "Finnish", no luck. Thx for trying to help:)
Janskis gravatar imageJanskis ( 2018-12-28 08:53:48 -0500 )edit

answered 2018-12-28 04:19:46 -0500

villykruse gravatar image
edit flag offensive delete link more


thank you co-answer.....Have a nice day^^

simmon gravatar imagesimmon ( 2018-12-28 06:54:31 -0500 )edit

Thanks, I have installed all packages mentioned in that question (except 2 which dnf can't find (python-libvoikko tmispell-voikko)). No help.

Janskis gravatar imageJanskis ( 2018-12-28 08:22:30 -0500 )edit

tmispell-voikko-0.7.1-21.fc29.x86_64 python3-libvoikko-4.1.1-1.fc29.noarch

simmon gravatar imagesimmon ( 2018-12-28 09:01:59 -0500 )edit

Thanks, now also those are installed but no luck.

Janskis gravatar imageJanskis ( 2018-12-28 09:23:12 -0500 )edit

Question Tools


Asked: 2018-12-27 17:55:37 -0500

Seen: 236 times

Last updated: Dec 28 '18