Ask Your Question

Keybord layout not found in list

asked 2018-12-21 07:41:16 -0500

umrinderpal gravatar image

updated 2018-12-22 03:34:30 -0500


I'm trying to add Punjabi(phonetic) layout keyboard. But this option is not present in the list of layouts but others are there related to my language. I have used this layout on Fedora 29 Gnome, but now I am using Fedora 29 cinnamon DE and this option is missing. I have checked ibus-m17n-1.3.4-27.fc29.x86_64 the package is installed responsible for Indian language layouts. In /usr/share/m17n this file is also present (pa-phonetic.mim) contain phonetic mapping.

plz, help me out. Thanks


I tried the following things but did not get keyboard layout working.

I started the ibus-daemon and also put this in as starting application. Now, in the system tray has keyword icon to select a keyboard layout. After right-clicking on the icon, I'm able to select Punjabi phonetic keyboard layout. But the problem is, still I am not able to write in Punjabi in a text file but in English only.


edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2018-12-21 12:44:07 -0500

updated 2018-12-30 04:21:35 -0500

I do not use English as my native language, so I understand your situation and I hope that this article help with you and other users.

ਮੈਂ ਆਪਣੀ ਮੂਲ ਭਾਸ਼ਾ ਵਜੋਂ ਅੰਗਰੇਜ਼ੀ ਨਹੀਂ ਵਰਤਾਂਗਾ, ਇਸ ਲਈ ਮੈਂ ਤੁਹਾਡੀ ਸਥਿਤੀ ਨੂੰ ਸਮਝਦਾ ਹਾਂ ਅਤੇ ਮੈਨੂੰ ਆਸ ਹੈ ਕਿ ਇਹ ਲੇਖ ਤੁਹਾਡੇ ਅਤੇ ਦੂਜੇ ਉਪਭੋਗਤਾਵਾਂ ਨਾਲ ਸਹਾਇਤਾ ਕਰੇਗਾ.

A.Keboard Layout - Punjabi KeyBoard Tested F29 / KDE test ਟੲਸਟ 테스트

You should install ibus in the system configuration, install the necessary package for ibus and library of non-English language support.

A-1 Library Install for Language Support..For related programs installation use *

# yum -y install  ibus-devel  ibus-gtk2 ibus-qt-devel ibus- ibus-setup ghc-language-java-devel ghc-language-java php-symfony-expression-language wxGTK wxGTK3-gl wxGTK3-media wxGTK-devel wxGTK3-devel im-chooser glibc glibc-devel glibc-common glibc-utils glibc-all-langpacks glibc-headers glibc-static glibc-langpack* system-config-language

And, if you set up another language input device without using ibus, you need to change the check, use and setting necessary for using the language input device.

Application Launcher - Application - Settings - Input Method Selector

The keyboard setting can be selected from the System Setup Input Method Selector by selecting the language selector (Ibus - fcitx) through the application for language setting, and selecting it via ibus and adding it to the corresponding language to be shown.

As a result of testing on a real server, the data presented by the questioner is normally located, and if there is no problem, ibus related to install or set for language support library and setting, etc.

You can also install and use it through ibus. You can find additional resources for language setting at the address below.

If you need more information, please let me know and I will respond to you. written by simmon

edit flag offensive delete link more


Thank for reply. Please check my updated question.

umrinderpal gravatar imageumrinderpal ( 2018-12-22 03:36:32 -0500 )edit

HI~ umrinderpal! All in all ... The problems that we face are all the same. Tested yesterday is well entered. This setup and use was tested in the KDE environment. Have a nice day!! written by simmom

simmon gravatar imagesimmon ( 2018-12-22 03:42:26 -0500 )edit

Thanks, now it is working

I have installed libraries as you suggested. but There is a different application in cinnamon (Input method selector) not part of the keyboard layouts app, from that app you need to select (iBus). but I want to say, Gnone is more simple to use and everything is working out of the box.

umrinderpal gravatar imageumrinderpal ( 2018-12-22 08:24:33 -0500 )edit

Question Tools

1 follower


Asked: 2018-12-21 07:41:16 -0500

Seen: 78 times

Last updated: Dec 30 '18