Ask Your Question

NVIDIA drivers not working on Fedora 28

asked 2018-12-14 03:57:41 -0500

ignatirabo gravatar image

updated 2018-12-20 07:13:52 -0500

SOLVED! Edit below.

I installed NVIDIA drivers according to My laptop is running Fedora 28 and has a NVIDIA 940m GPU next to the integrated Intel card, and the laptop has NVIDIA Optimus support.

The installation I did consists of 3 commands:

dnf install xorg-x11-drv-nvidia akmod-nvidia
dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support
dnf update -y

The packages are installed but when I run nvidia-settings I get the following output

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

When I run sudo modprobe nvidia then nvidia-settings just returns:

ERROR: Unable to load info from any available system

I tried finding if nouveau was running but lsmod | grep "nouveau" didn't return anything.

I'm far from being an expert or even an "advanced user". I have no clue on what to try to fix it and I didn't find any answer in the forums that could help me (probably because I don't know exactly what I'm searching for).

I'd really appreciate any idea on what could be wrong and hopefully some way to fix it.

Thanks in advance!


The output of nvidia-smi is:

Fri Dec 14 14:28:31 2018       
| NVIDIA-SMI 410.78       Driver Version: 410.78       CUDA Version: 10.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce 940M        Off  | 00000000:03:00.0 Off |                  N/A |
| N/A   48C    P0    N/A /  N/A |      0MiB /  2004MiB |      0%      Default |

| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |

Output of lsmod | grep nvidia:

nvidia_uvm            925696  0
nvidia              16621568  1 nvidia_uvm
ipmi_msghandler        69632  2 ipmi_devintf,nvidia

Output of lspci | grep VGA:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)


As I said in the comments, I do have Primus and it's working. The problem is with some applications. Here's the error message I get with primusrun glxspheres:

Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver:
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver:
libGL error: failed to load driver: swrast
Visual ID of window: 0x13a
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  48
  Current serial number in output stream:  47

EDIT 3: So the problem was very stupid. I tryed flatpak a long time ago, and I installed Steam with Flatpak but I didn't remember. This caused Steam to not find primusrun or optirun. Finally installing it thorugh the RPMFusion repo solved the issue. I don't know why primusrun glxspheres doesn't work but ... (more)

edit retag flag offensive close merge delete


Have you rebooted after installation?

What is the output of nvidia-smi and lsmod | grep nvidia and lspci | grep VGA?

Night Romantic gravatar imageNight Romantic ( 2018-12-14 05:49:45 -0500 )edit

I added the output of the commands you asked me.

ignatirabo gravatar imageignatirabo ( 2018-12-14 07:32:44 -0500 )edit

As far as I can see you have drivers installed properly and active.

Please post the output of lspci | grep -i nvidia as well.

I haven't got Optimus laptop, but it seems to me they use Intel gpu by default and NVidia one when asked for it.

Read this:

Night Romantic gravatar imageNight Romantic ( 2018-12-14 07:57:17 -0500 )edit

Look also here: -- section Optimus laptops. Author recommends just disabling Intel GPU in BIOS as it's never powers down when used with proprietary NVidia drivers.

Night Romantic gravatar imageNight Romantic ( 2018-12-14 08:12:25 -0500 )edit

Also on Archlinux Wiki there are plenty info here and here. Most of it applicable to Fedora without any changes.

As I haven't got an Optimus laptop I cannot give you short and definitive answer what to do, but I'll try to point you in the right (i hope ;-) ) direction and answer questions to the extent of my knowledge.

Night Romantic gravatar imageNight Romantic ( 2018-12-14 08:34:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-14 09:40:25 -0500

Night Romantic gravatar image

updated 2018-12-14 09:42:48 -0500

TLDR as far as I understand you have proprietary NVidia drivers installed and working (on an Optimus laptop).

From the links I provided in the comments above for Fedora you basically have two options:

  1. Disable Intel gpu in your laptop's BIOS/UEFI settings - if there's such an option. It's the simplest but you loose gpu switching.

  2. Use bumblebee -- see here.

There's also nvidia-xrun -- git page here, but I found no packages for F29 (only for F27-28).

It would be wonderful to hear from someone actually using Optimus laptop with Fedora. ;-)

edit flag offensive delete link more

Question Tools



Asked: 2018-12-14 03:57:41 -0500

Seen: 847 times

Last updated: Dec 20 '18