Ask Your Question
1

Automounted NTFS partitions have no trashcan (F29)

asked 2018-11-29 16:07:21 -0500

NewbietoFedora gravatar image

updated 2018-11-30 06:40:24 -0500

hhlp gravatar image

I just moved from F28 to F29. Everything is set up the same. But in F28 I figured out a way (it must have been fairly simple because I've forgotten it) to get a move to trash option working for both my NTFS drives. Now in F29 it says 'unable to find or create wastebasket directory for /mnt/NTFS/madeupdirectory/madeupfile' I edited fstab so it looks like this

units generated from this file.

# 
/dev/mapper/fedora-root / ext4 defaults 1 1 
UUID=99999999-9999-99999-99999-999999999 /boot ext4 defaults 1 2 
UUID=A999-999 /boot/efi vfat umask=0077,shortname=winnt 0 2 
/dev/mapper/fedora-home /home ext4 defaults 1 2 
/dev/mapper/fedora-swap swap swap defaults 0 0 
UUID=9999999999999 /mnt/NTFS ntfs defaults 0 0 
UUID=99999999999999 /mnt/NTFS2 ntfs defaults 0 0 
~
~

I remember this happened before on F28 and I fixed it quickly enough by deleting the .trash-1000 folder and making another .trash-1000 folder. But this doesn't seem to work now. In all other respects the NTFS partitions are behaving fine. What do I need to do to get the move to rubbish bin option back?

edit retag flag offensive close merge delete

Comments

Try again: delete the .Trash directory. Then do not manually recreate the directory. Let nautilus do it. If that doesn’t work, recreate it and make sure the number after .Trash- matches your user ID. Maybe it’s not 1000?!

florian gravatar imageflorian ( 2018-11-30 10:04:46 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-30 06:11:48 -0500

NewbietoFedora gravatar image

updated 2018-11-30 14:37:02 -0500

hhlp gravatar image

Sorry should of said Fedora 29 and Fedora 28

Also the output from terminal hasn't formatted properly

so once again

#
# /etc/fstab
# Created by anaconda on Thu Nov 29 19:15:20 2018
#
# Accessible filesystems, by reference, are maintained under '/dev/disk/'.
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info.
#
# After editing this file, run 'systemctl daemon-reload' to update systemd
# units generated from this file.
#
/dev/mapper/fedora-root /                       ext4    defaults        1 1

UUID=c733df65-54f0-4ab3-92e1-693e21d7211a /boot                   ext4    defaults        1 2

UUID=A167-E705          /boot/efi               vfat    umask=0077,shortname=winnt 0 2

/dev/mapper/fedora-home /home                   ext4    defaults        1 2

/dev/mapper/fedora-swap swap                    swap    defaults        0 0

UUID=999999999999999999   /mnt/NTFS               ntfs    defaults        0 0

UUID=999999999999999999   /mnt/NTFS2              ntfs    defaults        0 0

~
I think it's something simple I'm forgetting. Why can't I move to trash now in Fedora 29 what did I do in Fedora 28 that made it work? Any help would be apppreciated.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-11-29 16:07:21 -0500

Seen: 122 times

Last updated: Nov 30 '18