Ask Your Question

how to configure the computer and apache

asked 2018-11-24 10:56:34 -0500

noammo gravatar image

I have apache installed and I opened the ports and everything, but what else should I change or configure so I can access the website (in www) from other computers ?

edit retag flag offensive close merge delete



We need more information. Are you behind a router? Is Apache running ? Does it work on local host? Firewall? Work on your lan?

Panther gravatar imagePanther ( 2018-11-24 11:08:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-11-24 12:57:23 -0500

aeperezt gravatar image

Normally you need to install apache:

sudo dnf install httpd

start your apache service with:

sudo systemctl start httpd

Verify it is running with

sudo systemctl status httpd

You should get some output letting you know it is working.

To enable it to restart on reboot or turn on do

sudo systemctl enable httpd

then you need to open the firewall so it accept http and https connections

sudo firewall-cmd --add-service=http
sudo firewall-cmd --add-service=https

if you want those changes to be permanent you need to add --permanent to those command lines.

Then you could test using your browser on localhost and you should get Fedora apache page, if you want to test from another computer on the same network, you need to know your machine ip and access http://your-machine-ip.

By default all web content should be in /var/www/html/ so if you place your page in that folder you should start accessing it.

if you cannot access your machine with a browser from other machine on the same network verify your firewall settings with

firewall-cmd --list-services

it should show http and https services, if there is other device or you want to access your pc from outside your network, then you need to proper configure your firewall device for that.

Good Luck

edit flag offensive delete link more


It works, thanks a lot !! Just one more thing, how can I make it that everyone can access it ? (Just like a host) - that people will enter the website with my public ip - I opened the port in the router, but I guess that I need to something else ? because now when I type my public ip so it doesn't work

noammo gravatar imagenoammo ( 2018-11-24 14:14:21 -0500 )edit

That depends on you router normally you can do is to set a dmz (demilitarized zone on your firewall) allowing all traffic to your pc or do a port forward from your router port 80 and 443 to the ip of your pc. But that configuration will depend on the firewall maker on how to do it, and goes beyond Fedora help. So you have the idea of what to do. You need to google your firewall manufacture on how to do it.

aeperezt gravatar imageaeperezt ( 2018-11-24 17:21:32 -0500 )edit

thanks, so in fedora I don't need to change anything else ? like if it works in the local network, so all the setting are good ?

noammo gravatar imagenoammo ( 2018-11-25 02:01:25 -0500 )edit

Correct, if work on the Lan it will work.

aeperezt gravatar imageaeperezt ( 2018-11-25 08:31:59 -0500 )edit

Sorry for all of the questions, but it works in the same network, but not when I'm trying with the public ip - I forwarded the ports, but it still doesn't work. Should I change something in the apache settings so it will work with the public ip and not the private ip ? I tried to search a lot, but I didn't find anything about that - I found just things about what you explained before (when it's in the same network)

noammo gravatar imagenoammo ( 2018-11-25 13:51:26 -0500 )edit

Question Tools

1 follower


Asked: 2018-11-24 10:56:34 -0500

Seen: 57 times

Last updated: Nov 24 '18