Ask Your Question
1

How can I disable ATI GPU?

asked 2018-11-24 10:48:22 -0500

umrinderpal gravatar image

updated 2018-11-24 21:27:36 -0500

I am trying to switch off the GPU

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

But this command is not working.

cat  /sys/kernel/debug/vgaswitcheroo/switch

0:DIS: :DynOff:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

I want completely shut down the GPU

Fedora 29

Radeon HD 7550M

Linux localhost-fedora29 4.18.17-300.fc29.x86_64 #1 SMP Mon Nov 5 17:56:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Plz help

UPDATE: as per @ozeszty on running the commands

#DRI_PRIME=1 glxgears

radeon: Failed to allocate a buffer:
radeon:    size      : 65536 bytes
radeon:    alignment : 4096 bytes
radeon:    domains   : 2
radeon:    flags     : 4
radeon: Failed to allocate a buffer:
radeon:    size      : 65536 bytes
radeon:    alignment : 4096 bytes
radeon:    domains   : 2
radeon:    flags     : 4
radeon: Failed to allocate a buffer:
radeon:    size      : 4096 bytes
radeon:    alignment : 4096 bytes
radeon:    domains   : 2
radeon:    flags     : 0
radeon: Failed to allocate a buffer:
radeon:    size      : 4096 bytes
radeon:    alignment : 4096 bytes
radeon:    domains   : 2
radeon:    flags     : 0
radeon: The kernel rejected CS, see dmesg for more information (-16).
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  148 ()
  Minor opcode of failed request:  2
  Serial number of failed request:  40
  Current serial number in output stream:  41

For a seconds output changes to this for and goes back to the previous stage

#watch -n 1 cat /sys/kernel/debug/vgaswitcheroo/switch
    0:DIS: :DynPwr:0000:01:00.0
    1:IGD:+:Pwr:0000:00:02.0
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-11-24 15:28:03 -0500

ozeszty gravatar image

Hi, do you have any issues with this GPU? It is already off and is managed by system automatically.

Run watch -n 1 cat /sys/kernel/debug/vgaswitcheroo/switch (it'll rerun cat every second) and DRI_PRIME=1 glxgears in second terminal. You'll see that 0:DIS (discrete GPU) will dynamically turn on, and, after closing glxgears, off. DRI_PRIME=1 environment variable tells system to use discrete GPU to do the rendering for run application. Other than that, this GPU might be woken up to do some OpenCL or video decoding work, if some application is able to use it.

You may not be able to get rid of AMD GPU completely, because display outputs might be interconnected between GPUs.

Anyway, Intel/AMD hybrid graphics in my laptop works flawlessly out of the box, and overall system power draw is better than it ever was on Windows. If you wan't to improve battery runs, look at the middle of this answer: https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more

Comments

Hi, Thanks for Reply But getting this problem now, plz check my updated question.

umrinderpal gravatar imageumrinderpal ( 2018-11-24 21:28:53 -0500 )edit

Have you so far applied any changes in trying do disable the GPU? It would be easier if we knew whether this issue happened also with out of the box Fedora.

ozeszty gravatar imageozeszty ( 2018-11-25 06:17:10 -0500 )edit

Sorry for the late reply No, I didn't change anything. I have also checked this thing in live-image and showing the same error.

umrinderpal gravatar imageumrinderpal ( 2018-11-29 23:08:00 -0500 )edit
0

answered 2018-11-25 04:59:52 -0500

cim gravatar image

updated 2018-11-27 03:46:53 -0500

EDIT: Actually add this to your boot params in GRUB and this will completely power down Radeon:

systemd.mask=alsa-state rd.driver.blacklist=radeon

After booting, you can verify by typing sudo cat /sys/kernel/debug/vgaswitcheroo/switch and the output should be:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Off:0000:01:00.0
2:DIS-Audio: :DynOff:0000:01:00.1

Try adding rd.driver.blacklist=radeon to your GRUB boot entry.

edit flag offensive delete link more

Comments

Hi, I tried this ,

GRUB_CMDLINE_LINUX="resume=UUID=2f80e7a5-fc62-40cd-9686-7e9f694cf458 rhgb quiet rd.driver.blacklist=radeon"

Now Output:

# cat /sys/kernel/debug/vgaswitcheroo/switch 
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0
umrinderpal gravatar imageumrinderpal ( 2018-11-29 23:17:15 -0500 )edit

Looks like it's working now. Did you also put systemd.mask=alsa-state ?

cim gravatar imagecim ( 2018-12-02 05:39:42 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-11-24 10:47:33 -0500

Seen: 584 times

Last updated: Nov 27 '18