Ask Your Question

cannot adjust screen brightness only as root - some privileges problem

asked 2018-11-23 13:20:25 -0500

roberto68 gravatar image

updated 2018-11-26 02:44:20 -0500

I cannot change screen brighntess whether it is via g panel, xfce panel, xrandr, xbacklight or keyboard. I start gnome session as root and it worked so defo problem with privelieges. I pasted ls-l of a folder which /sys/class/backlight/intel_backlight symlink points at (where the actual files are /sys/devices/..../intelput it on pastebin caus of better format option I've also created /etc/udev/rules.d/backlight.rules and added those lines

 ACTION=="add", SUBSYSTEM=="backlight", KERNEL=="intel_backlight", RUN+="/bin/chgrp video /sys/class/backlight/%k/brightness"
ACTION=="add", SUBSYSTEM=="backlight", KERNEL=="intel_backlight", RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"

according to the but that doesn't do anythign about that Thanks Rob

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2018-11-24 10:54:20 -0500

ed209 gravatar image

Well, only root can change stuff in /sys, of course. But if you add your user to video group the rules you've written could work.

edit flag offensive delete link more


I did that but I got No outputs have backlight property so according to this I uncomented and edited this line Option "Backlight" intel_backlight in /etc/X11/xorg.conf but this could only work under Xserver doesn't work with wayland obviously

roberto68 gravatar imageroberto68 ( 2018-11-26 03:03:31 -0500 )edit

Your solution seems acceptable. Better not mess around, and I doubt very much you could modify wayland in this sense anyway.

ed209 gravatar imageed209 ( 2018-11-26 08:31:04 -0500 )edit

answered 2018-11-27 16:21:53 -0500

roberto68 gravatar image

so I "solved it" (bypass is a better word) I installed cockpit and I'm using it in icecat (limited to localhost) and use this solution So I am running that script thru root terminal which cockpit provides (I cannot login as root in "normal terminal"). Quite hacky but it works :D

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-11-23 13:20:25 -0500

Seen: 217 times

Last updated: Nov 27 '18