cockpit web

asked 2018-11-19 09:42:57 -0500

gmcms gravatar image

Hi, using the last Fedora Atomic, I installed the cockpit web interface as a container using:

  • sudo atomic install cockpit/ws sudo
  • vi /etc/systemd/system/cockpitws.service

    [Unit]

    Description=Cockpit Web Interface

    Requires=docker.service

    After=docker.service

    [Service]

    Restart=on-failure

    RestartSec=10

    ExecStart=/usr/bin/docker run --rm --privileged --pid host -v /:/host --name %p cockpit/ws /container/atomic-run --local-ssh

    ExecStop=-/usr/bin/docker stop -t 2 %p

    [Install]

    WantedBy=multi-user.target

When the system shutdown it takes a lot of time with message "a job is running for cockpit web interface". The purpose is to have cocpit web interface container start at boot time. Is there any reason and/or workaround except reducing the #DefaultTimeoutStopSec=90s in /etc/systemd/system.conf?

Thanks

Regards

edit retag flag offensive close merge delete