SELinux prevents me from login in

asked 2018-11-16 23:02:18 -0500

pedroffleck gravatar image

I just installed Fedora 29 and I couldn't make it boot (a lot of things failed, like NetworkManager and GDM), I reinstalled numerous times with different settings and then I tried booting with GRUB command "selinux=0" and it worked. Then I reboot and tried to boot with SELinux enabled again: now I can't login, not in GDM neither in command line. Setting it to permissive doesn't work either. What can I do?

edit retag flag offensive close merge delete

Comments

Hi, have you tested your installation media before installation? It's the default option when you're live-booting Fedora. Also check your disk's S.M.A.R.T. report for any errors.

ozeszty gravatar imageozeszty ( 2018-11-17 05:03:21 -0500 )edit

I tested the media and there's no S.M.A.R.T errors.

pedroffleck gravatar imagepedroffleck ( 2018-11-17 06:59:22 -0500 )edit

Try installing using https://dl.fedoraproject.org/pub/alt/...

Those images contains updates up until 19 XI 2018, so a bug you're hitting might be fixed thre.

ozeszty gravatar imageozeszty ( 2018-11-22 02:22:19 -0500 )edit