Ask Your Question

Start job dev-mapper-fedora\x2dhome.device not finishing on boot

asked 2018-11-08 07:08:56 -0500

ET gravatar image

updated 2018-11-08 09:08:50 -0500

I'm using Fedora 29 with a LUKS encrypted drive, and wanted to switch to KDM from GDM, so I issued the following commands:

sudo dnf install kdm
systemctl disable gdm
systemctl enable kdm

But once the reboot was done, I cannot login to my Fedora system now. Once I enter my password for the encrypted drive it is stuck at starting the job dev-mapper-fedora\x2dhome.device. Why is this happening and how can I overcome it? Same happens if I try to use one of the earlier kernels or the rescue option. Here is a picture of what I get when booting.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-11-08 07:33:45 -0500

aeperezt gravatar image

After you enter the luks password do ctrl+alt+f3 then enter your user and password then enable gdm again so you can use your system, not sure how to enable kdm. Hope it helps.

edit flag offensive delete link more


CTRL+ALT+F3 doesn't do anything. I updated the original question with a picture of what I get. Doing CTRL+ALT+F2 or ESC actually opens the view that is on my picture above.

ET gravatar imageET ( 2018-11-08 09:08:11 -0500 )edit

Ok, What the image show is that your pc is having trouble to mount one of the lvm partition, You may need to boot on rescue mode or with and installation media and use the recovery tool to see if your can fix that.

aeperezt gravatar imageaeperezt ( 2018-11-09 10:37:25 -0500 )edit

Thanks. I tried rescue mode, but it was still giving the same error. Since I didn't have anything valuable on my Fedora machine, I just re-installed fedora completely.

ET gravatar imageET ( 2018-11-10 07:41:28 -0500 )edit

Question Tools

1 follower


Asked: 2018-11-08 07:08:56 -0500

Seen: 126 times

Last updated: Nov 08 '18