How to disable GNOME's 8 sec. shift hotkey for activating slow keys/keystroke delay?

asked 2018-10-23 12:49:19 -0500

rugk gravatar image

When I press Shift for 8 seconds (as the upcoming dialog says, I rather feel these are 10 seconds) GNOME enables "slow keys", how they call it.

Fortunately a dialog pops up before it is finally enabled. However that cannot be quickly dismissed by navigation with the keyboard (you can only _click_ on "Cancel", moving with the keyboard's arrow keys does not work) or by pressing ESC. I found out, however, that you can close it by holding ESC for several seconds, too. (I would add a screenshot of that prompt here, but unfortunately this is not possible to screenshot it.)

My use case is just gaming on Linux or stuff like this, where it is perfectly fine when you hold the shift key for a longer time. As such, I do not want this dialog to pop up and dismissing it in the middle of a game is also _very_ annoying.

As such my question is: How can I disable this prompt for enabling the keystroke delay?

The help file already linked above does state there is a setting for it:

Under Enable by Keyboard, select Turn on accessibility features from the keyboard to turn slow keys on and off from the keyboard. When this option is selected, you can press and hold Shift for eight seconds to enable or disable slow keys.

However, the mentioned setting _is already disabled_ in my case: Setting "Enable by keyboard" with description "Turn accessibility features on and off using the keyboard" is shown in disabled state with a slider in "Off" position. Title of the window: "Typing Assist"

GNOME 3.28.2, Fedora 28

This question has been cross-posted on

edit retag flag offensive close merge delete


Just FYI, holding any of my shift buttons down for > 20 sec doesn't do anything. Is this under Wayland or Xorg?

florian gravatar imageflorian ( 2018-10-23 13:29:12 -0500 )edit

Actually it turned out this is a bug.

rugk gravatar imagerugk ( 2019-01-23 09:07:45 -0500 )edit