Ask Your Question

Fstab makes drive unwritable after boot

asked 2018-10-16 07:14:05 -0500

MrMarcie gravatar image

Hi, I tried f.e. /dev/sdd1 /run/media/user/USERNAME/ ntfs defaults 0 2

But after reboot drive mounts but is not writable by me, only root. If I do not mount the drive at boot the drive is r]=writable by me.

I switched off Hibernate and fast startup in windows 10.

How can I boot the drive at startup and keep it writable for me. I search a lot but can find the answer anywhere.

edit retag flag offensive close merge delete


double check that fast startup is actually disabled. You are describing exactly what happens with fast startup still active.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-10-16 14:22:13 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2018-10-23 09:24:36 -0500

MrMarcie gravatar image

I even found a much simpler solution. Just go to ACCESSORIES >> DISKS and open.

Choose the desired disk, click 'Additional partiton settings´ icon and select ´Edit Mount options' and slide USER SESSIONS DEFAULT off and click autostart at mount.


edit flag offensive delete link more

answered 2018-10-16 10:37:30 -0500

florian gravatar image

updated 2018-10-16 10:40:06 -0500

You need to set permissions using umask.

You can also set the owner and group using uid and gid mount options.

Check out this Q/A and see if you can make it work.

edit flag offensive delete link more



Wauw, this is very difficult. I finally solved it with this:

UUID=38C43F84417xxxxx /run/media/xxxx/XXXX/ ntfs auto,users,uid=1000,gid=1000,d$

Also works:

/dev/sdd1 /run/media/xxxx/XXXX/ ntfs auto,users,uid=1000,gid=1000,d$

Thanks everybody for their help and suggestions.

MrMarcie gravatar imageMrMarcie ( 2018-10-18 12:42:51 -0500 )edit

answered 2018-10-16 10:38:44 -0500

ed209 gravatar image

Should read ntfs-3g instead of ntfs . And use UUID instead of device name sdd1 .

edit flag offensive delete link more

Question Tools


Asked: 2018-10-16 07:14:05 -0500

Seen: 107 times

Last updated: Oct 23 '18