Ask Your Question

Error while partitioning for fedora 28

asked 2018-10-11 06:52:33 -0500

aswinvv gravatar image

I was trying to install fedora 28 along with windows 10 in my dell inspiron 15 3558 system. While partitioning i gave a root partition and a boot/efi partition too but an error coming up. The error saying that i have to give a GPT formated drive for /boot/efi partiton.

My syatem uses legacy mode initially for installing fedora 28 i changed bios to UEFI mode.

I really need this fedora 28 dual booted with windows 10. Please help me to solve the problem.

edit retag flag offensive close merge delete


Don't ever change the mode of your BIOS firmware after you have installed a system. Go with what your existing OS is configured with. If you WIn10 is in legacy mode, stick to it for your Fedora installation.

florian gravatar imageflorian ( 2018-10-11 08:59:53 -0500 )edit

Thanks for your advice.

aswinvv gravatar imageaswinvv ( 2018-10-11 13:00:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-10-11 07:25:47 -0500

ozeszty gravatar image

If Windows is installed in legacy mode, you have to install Fedora in the same mode. So either disable UEFI boot in BIOS or open your computer's boot menu (one of F8 - F12 keys should work) and choose legacy entry for your USB device. Legacy Fedora boot menu has some blue elements.

If Windows is installed in UEFI mode, you have to use the same mode for Fedora and choose existing windows EFI partition to be mounted as Fedora's /boot/efi. Fedora's boot menu in UEFI mode is all black and white - installation from your question was run in this mode.

edit flag offensive delete link more


Thanks for your answer

aswinvv gravatar imageaswinvv ( 2018-10-11 12:59:59 -0500 )edit

You're welcome. Have fun on Fedora!

ozeszty gravatar imageozeszty ( 2018-10-11 13:49:12 -0500 )edit

Question Tools

1 follower


Asked: 2018-10-11 06:52:33 -0500

Seen: 73 times

Last updated: Oct 11 '18