Ask Your Question

ufw not enabled on startup

asked 2018-09-16 01:24:27 -0500

mb3 gravatar image

Hey! Because I was not familiar with firewalls in fedora, I installed ufw. Unfortunately, it is always disabled by default when I boot into my computer. The ufw.conf file says to enable it upon startup but it does not. Suggestions? (I'm also ok with other firewall software suggestions; I just need help using it).

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2018-09-16 02:16:23 -0500

hhlp gravatar image

updated 2018-09-16 02:43:38 -0500

On these steps, you’ll install a new firewall manager. So it’s important to disable any other firewall you have on your system.

The following lines will disable the built in Fedora’s firewall and the iptables, if enabled:

systemctl stop iptables  
systemctl stop firewall  

Check if everything is ok

If for some reason the ufw doesn’t already have enable, just run the command below. To check if everything is working ok, just run sudo ufw status verbose and you have to see the message “Status: active”

sudo ufw enable
sudo ufw status verbose

How to use

If you want to learn how to use, I strongly recommend you to check to official Ubuntu documentation about UFW. Just it:


About firewalld that is the default fedora package

you can find all information in these pages :

  1. documentation
  2. wiki
  3. quick-docs

Related question here -> 126405


edit flag offensive delete link more


Thanks for the tip. Do you think this is safe though? It feels weird to disable firewall/iptables and to use a firewall that usually debian-based distributions use. I just really love ufw because I can just do sudo ufw enable and forget about it.

mb3 gravatar imagemb3 ( 2018-09-18 10:40:02 -0500 )edit

@mb3 , yes is safe you don't have to have 2 firewall enable

hhlp gravatar imagehhlp ( 2018-09-18 11:13:33 -0500 )edit

Question Tools

1 follower


Asked: 2018-09-16 01:24:27 -0500

Seen: 341 times

Last updated: Sep 16 '18