Screen Tearing Fedora 28 Gnome on Xorg

asked 2018-09-06 23:44:32 -0500

Jeff Shee gravatar image

image description

I had spent days for solution, but nothing work so far, please help!
Things I had tried:

/etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"
EndSection

/etc/X11/xorg.conf.d/20-modesetting.conf
Section "Device"
Identifier "Intel Graphics"
Driver "modesetting"
Option "AccelMethod" "glamor"
Option "DRI" "3"
EndSection

(both of these caused Xorg failed to boot...)

lspci -k

00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
    Subsystem: Acer Incorporated [ALI] Device 1037
    Kernel driver in use: i915
    Kernel modules: i915
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
    Subsystem: Acer Incorporated [ALI] Device 1037
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia

inxi -G

Graphics:  Card-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel 
           Card-2: NVIDIA GM107M [GeForce GTX 950M] driver: nvidia v: 396.54 
           Display: x11 server: Fedora Project X.org 11.0 driver: modesetting,nvidia unloaded: nouveau 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 950M/PCIe/SSE2 v: 4.6.0 NVIDIA 396.54 

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Intel HD 520 is notorious for tearing and other issues (even on Windows). Any way to disable the 520 from your BIOS/EFI and then just troubleshoot the GTX solo? Sorry if I'm missing something obvious, just trying to isolate.

It appears you are loading the both the proprietary and opensource drivers for the nVidia. I don't use nVidia, but I think you should blacklist the nouveau drivers or remove the proprietary ones (someone more familiar with nVidia setups will/should chime in)

suspiciousmilk gravatar imagesuspiciousmilk ( 2018-09-07 06:58:57 -0500 )edit

Thanks, too bad mine is a nvidia optimus device (Acer Aspire V15 Nitro), which doesn't have such feature in BIOS/EFI to disable either one of the graphic card.

Jeff Shee gravatar imageJeff Shee ( 2018-09-07 08:18:01 -0500 )edit

If you opt for the proprietary drivers, here is some good info on Optimus on Fedora:

https://docs.fedoraproject.org/en-US/quick-docs/bumblebee/index.html

suspiciousmilk gravatar imagesuspiciousmilk ( 2018-09-07 12:45:23 -0500 )edit