Ask Your Question

X11 Forwarding with Eclipse does not work with Fedora 28

asked 2018-08-27 17:13:28 -0500

fsheath gravatar image

I previously was able to use ssh -X to access my Fedora machine and use Eclipse. I can not do so now. I made the changes requred in sshd_config. When I ssh -X, I can start xterm and it starts on the other machine's display. When I start Eclipse it comes up on the Fedora machine not the remote.

I tried ssh -Y with the same results.

edit retag flag offensive close merge delete


Is it possible that Eclipse starts with a wayland backend? If yes, you may want to try setting GDK_BACKEND=x11 before running eclipse to make sure it uses the X11 backend.

genodeftest gravatar imagegenodeftest ( 2018-08-28 04:18:53 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-08-28 15:17:07 -0500

fedofix gravatar image

updated 2018-08-28 15:19:23 -0500

Disable Wayland. Then Reboot then Verify that /etc/ssh/sshd_config has :

     X11Forwarding yes
        X11UseForwarding yes

An interesting thing to quote :

"get X11 forwarding working over ssh, you'll need 3 things in place.

Your client must be set up to forward X11. Your server must be set up to allow X11 forwarding. Your server must be able to set up X11 authentication."

edit flag offensive delete link more

answered 2018-08-29 08:46:14 -0500

fsheath gravatar image

GDK_BACKEND worked Thanks

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-08-27 17:13:28 -0500

Seen: 387 times

Last updated: Aug 29 '18