Ask Your Question
0

Wifi not working with fedora 28 on surface pro 2

asked 2018-08-21 20:43:21 -0500

updated 2018-08-25 13:28:37 -0500

When I first install fedora 28 (kernel 4.16.3-301) on my surface pro 2, wifi worked fine. After the first kernel update (4.17.12-200) wifi stopped working. A subsequent kernel update (4.17.14-202) did not solve the problem. If I boot into the originally installed kernel (4.16.3-301) from the grub menu, wifi works fine. All other updates are applied, which suggests it is the kernel that is the problem. But that is the only way I can get wifi to work. I have tried other adapters, no luck.

Any suggestions?

Edit: I can confirm that the driver is loaded, and also that networks are found. I just can't connect to any.

[cbrown@surfacepro2 ~]$ lsusb -t
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/9p, 480M
    |__ Port 1: Dev 2, If 2, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 1: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 2: Dev 8, If 2, Class=Vendor Specific Class, Driver=mwifiex_usb, 480M
    |__ Port 2: Dev 8, If 0, Class=Wireless, Driver=btusb, 480M
    |__ Port 2: Dev 8, If 1, Class=Wireless, Driver=btusb, 480M
    |__ Port 3: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 3: Dev 4, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 3: Dev 4, If 2, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 4: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 4: Dev 5, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 5: Dev 6, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 5: Dev 6, If 1, Class=Video, Driver=uvcvideo, 480M
    |__ Port 6: Dev 7, If 0, Class=Video, Driver=uvcvideo, 480M
    |__ Port 6: Dev 7, If 1, Class=Video, Driver=uvcvideo, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
[cbrown@surfacepro2 ~]$ lsmod | grep mwifi
mwifiex_usb            28672  0
mwifiex               331776  1 mwifiex_usb
cfg80211              770048  1 mwifiex
[cbrown@surfacepro2 ~]$
edit retag flag offensive close merge delete

Comments

Hi, can you provides us qith a lspci ? No idea what driver/HW are you dealing there. You most probably just need to reload the driver. Cheers

casep gravatar imagecasep ( 2018-08-22 09:37:41 -0500 )edit

Network Manager lists it as "Marvell Bluetooth and Wireless LAN Composite Device". I don't see it in lspci, but it shows up if I lsusb:

Bus 002 Device 009: ID 1286:2044 Marvell Semiconductor, Inc.

codebreaker gravatar imagecodebreaker ( 2018-08-22 18:10:23 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-09-12 12:16:22 -0500

Update: WIFI appears to be working with the latest kernel update to 4.18.5-200.

edit flag offensive delete link more
0

answered 2018-08-22 13:23:37 -0500

fedofix gravatar image
edit flag offensive delete link more

Comments

Not sure that will help, since as I mentioned my wifi actually works with a particular kernel. So a missing driver can't be the problem. But thanks.

codebreaker gravatar imagecodebreaker ( 2018-08-22 18:12:29 -0500 )edit

Hi, in linux things work slightly different, so there is a tight relationship between a kernel and the drivers. The driver (module) could be loading correctly on a kernel, but not for others, unless you re-load it, force it. The wireless adaptor you mention seems to be a difficult one, You may need to re-install the driver on the new kernel.

casep gravatar imagecasep ( 2018-08-23 11:02:31 -0500 )edit

On newer kernels in which I cannot get wifi working, network manager sees the device and lists available wifi networks, but just can't connect. I interpret this to indicate that device drivers are loading. Am I mistaken?

codebreaker gravatar imagecodebreaker ( 2018-08-25 09:30:56 -0500 )edit

@fedofix please elaborate your question a link reference ins't enough

hhlp gravatar imagehhlp ( 2018-08-26 03:01:53 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-08-21 20:43:21 -0500

Seen: 225 times

Last updated: Aug 25 '18