Ask Your Question
1

NVIDIA GPU is always on, how do I change its behavior to run only when specifically asked?

asked 2018-08-19 05:19:17 -0500

quexth gravatar image

Hello,

I am using a Dell Inspiron 15 7567 laptop with an Intel 7700HQ cpu and a 1050Ti gpu and I have an (almost) clean install of Fedora 28. I have been having hardware issues with Linux for the entire time (previously used Ubuntu) I used it and newer kernels made it worse.

My problem is that the NVIDIA gpu is always on and it significantly reduces battery life and causes heating. I would like to use the integrated graphics all the time and only use the NVIDIA gpu when I specifically turn it on, preferably without rebooting. I had to disable the dGPU entirely before and I am hoping for a better solution.

I have read that the new nouveau drivers handle Optimus laptops to switch the load between integrated graphics and dGPU and I guess it is somewhat working because my estimated time remaining significantly changed while I was writing this post (currently only a single instance of Firefox and Terminal is running). Even then using Win10 I can get battery life longer than 6 hours and in Linux it seems that I can get 4 hours tops without disabling the dGPU.

While searching for a solution I read that people were enabling the dGPU on a process basis via the command line and that is the best case solution I am hoping for.

Running some commands I found returns the following:

glxinfo | grep "OpenGL renderer"
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)

lspci | grep 'VGA'
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

xrandr --listproviders
Providers: number : 0

xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 77.00*

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-20 05:13:02 -0500

jamessmith1403 gravatar image

updated 2018-08-20 12:30:32 -0500

Here is the answer -> link. I had the same problem, and it was the solution. Make sure to read the comments, there you can find some additional information.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-08-19 05:19:17 -0500

Seen: 627 times

Last updated: Aug 20 '18