Ask Your Question

tracker taking huge cpu

asked 2018-08-12 14:15:43 -0500

billwilliams gravatar image

This is spyware nobody should have to put up with. It's causing my fan to race since the most recent updates.

First of all, this should be removed permanently from fedora and never allowed back again.

Second of all, there are a bunch of posts on how to disable it but that isn't good enough. I want this $HIT OFF MY PC.

Yes, I am outraged. I do not want any crapware or spyware doing anything that I didn't request. I don't need indexing or searching, I could use Windows if I wanted to live that way.

Just STOP doing this.

edit retag flag offensive close merge delete


And thank you if anyone can explain how to delete any databases or files this created

billwilliams gravatar imagebillwilliams ( 2018-08-12 14:24:54 -0500 )edit

In terms of „huge CPU“, this is a known problem:

Other than that disable tracker, delete the db (tracker reset -- hard), and relax!

florian gravatar imageflorian ( 2018-08-12 15:12:25 -0500 )edit

3 Answers

Sort by » oldest newest most voted

answered 2018-08-12 22:38:54 -0500

abadrinath gravatar image
sudo dnf remove tracker

Should do the trick (make sure you don't accidentally remove something that's needed)! If you don't want to be so forceful, try disabling the following services:


There are some tricks to disabling it by messing around with the ~/.config directory; seems like a pain though. The above should work fine.

edit flag offensive delete link more



Thanks, unfortunately this tries to remove a huge number of packages. Does not seem like a good idea.

I will try your suggestions on disabling the services.. I'm new to systemd, could you explain which command(s) to use please?



billwilliams gravatar imagebillwilliams ( 2018-10-08 07:00:16 -0500 )edit

Apologies for the late answer and I'm sure you've resolved this already but the command is systemctl disable ___.service

abadrinath gravatar imageabadrinath ( 2019-01-31 02:31:46 -0500 )edit

answered 2018-10-15 14:27:29 -0500

billmcgonigle gravatar image

What is the carbon footprint of this misfeature? It must be enormous. My CPU has been running one core at 100% for over a week on it, according to my monitoring charts (about 30W). Multiply that by every Fedora user who never opted in to this.

I found this on another thread:

gsettings set org.freedesktop.Tracker.Miner.Files enable-monitors false
gsettings set org.freedesktop.Tracker.Miner.Files crawling-interval -2
gsettings set org.freedesktop.Tracker.Miner.Files ignored-files "['*']"

and then

tracker reset -r


edit flag offensive delete link more


Just update and you should be good. If not, file a new issue.

florian gravatar imageflorian ( 2018-10-15 14:51:47 -0500 )edit

answered 2018-12-02 12:23:34 -0500

billwilliams gravatar image

I tried various things but tracker came back again. So I removed it. In the process I lost the workspace tabs on the bottom of the gnome display. But in the end this was good. I am quite sick of Linux bloat and most of that is really gnome bloat.

In the past I used fluxbox and I decided to look into i3. i3 seems easy to use. I have a problem getting gnome keyring unlocked (good example of gnome bloat, everything depends on everything else) but when that is resolve I'll get back to minimizing my use of gnome stuff.

edit flag offensive delete link more


I dumped Gnome years ago then went to Fluxbox which was good but now have been using LXDE since 19 which works great. Gnome is a real pig. You're right, if I wanted windows I'd be using windows.

how0909 gravatar imagehow0909 ( 2018-12-03 21:49:02 -0500 )edit

Question Tools

1 follower


Asked: 2018-08-12 14:15:43 -0500

Seen: 822 times

Last updated: Dec 02 '18