Ask Your Question
1

Using GNOME in X11 for particular program

asked 2018-07-29 02:59:56 -0500

Sudharaka gravatar image

Hi everyone,

I was reading the following article;

https://docs.fedoraproject.org/f27/sy...

It seems to suggest that each program by default uses Wayland server by default and that the's an option to choose X11 on the login screen. I am using GNOME and I do not see this option.

1) Is there specific steps I need to do in order to see this option on login screen.

2) More importantly I would like to force X11 on a program to program basis. That is use X11 for certain programs. Is this possible? If so could someone point me to the instructions.

Thanks so much for your time.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2018-07-29 13:33:10 -0500

genodeftest gravatar image

Question #2: If you want to run an application with X11 backend even within a Wayland session, you may try using a toolkit-specific switch to enforce X11.

For Gtk+, set the GDK_BACKEND environment variable. Open a terminal and execute GDK_BACKEND=X11 gedit for example.

For Qt, the default (in Fedora 28, as of 2018-07-29 and earlier) is to start any application with X11 backend. This may change in the future. the -platform command line option may help. Right now, you can enforce using the wayland backend by executing a Qt5 application like this: kwrite -platform wayland. There is probably an option for X11 too.

edit flag offensive delete link more
0

answered 2018-07-30 00:28:06 -0500

Sudharaka gravatar image

Hi everyone,

Thanks a lot for your responses. I figured out switching to X11 through mralk3's suggestion (thank you).

For #2 I am just gonna select X11 for now at login screen for now since I just found out that the exact issue that I am facing has been recorded and is a work in progress by the Wayland team; https://bugzilla.redhat.com/show_bug....

Thanks again for all your answers.

edit flag offensive delete link more
3

answered 2018-07-29 10:02:17 -0500

mralk3 gravatar image

Question #1: In order to use native X11 you need to log out of your current GNOME Session. then Click your name and next to the "Sign In" button there is a little gear box. Click the gear box and you will be presented with the session options on your system. Select "GNOME on Xorg".

Question #2: This may be only partially correct, but it is the way I understand it. Wayland runs applications that only support X11 using the "XWayland" framework. Each time an X11 application is ran this framework launches a new process to host the applications and the application thinks it is still using X11. This should be done automatically and seamlessly in Fedora 28.

Reference link text

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-07-29 02:59:56 -0500

Seen: 375 times

Last updated: Jul 30 '18