Ask Your Question

Cannot install Nvidia driver

asked 2018-06-25 14:05:56 -0500

asder gravatar image

updated 2018-06-26 02:43:39 -0500

Hello , in the process of trying to change from nouveau to the Nvidia driver I restarted my PC and Nvidia driver installation fails saying it doesn't find kernel source tree ๐ŸŒฒ

Thank you,

Edit errors I get: image description

image description

image description

edit retag flag offensive close merge delete



What version of fedora? What driver did you try, rpm or proprietary? what steps did you take to install, did you follow a guide?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-06-25 15:33:47 -0500 )edit

I am on Fedora 27 (4.13) and I downloaded the latest .run file for Nvidia website (390.64) I went with that route

asder gravatar imageasder ( 2018-06-25 16:44:21 -0500 )edit

why not use nvidia driver from rpm fusion repos ( or negativo17 nvidia repo (

Rabin gravatar imageRabin ( 2018-06-26 00:59:13 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-06-26 03:44:34 -0500

asder gravatar image

updated 2018-06-26 10:04:15 -0500

I fixed doing the folowings:

dnf  -y remove \*nvidia\*

I manually removed every file related to nvidia. And I tried again.

P.S. to enter no-gui mode since Desktop was freezing I added 3 at end of the kernel line of the grub entry.

edit flag offensive delete link more


e at the grub menu, lets you modify the entry, so what did you put on the linux commandline? if you are working now, what method did you end up using? the errors look like the devel and headers for your kernel may have been missing. did you read the log files?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-06-26 07:17:39 -0500 )edit

Sorry 3 , I wanted to write pressed e and entered 3 ๐Ÿ˜‚

asder gravatar imageasder ( 2018-06-26 08:54:20 -0500 )edit

answered 2018-06-25 17:01:09 -0500

SteveEbey73701 gravatar image

These are the steps to properly install the nvidia drivers. the link you reference is over 5 years old and the driver installer from nvidia has changed. hope this helps.

start terminal

sudo -i
dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r) --force
systemctl set-default 

login as root

dnf install kernel-devel-$(uname -r) gcc dkms acpid
bash /dirofsavedfile/ 
systemctl set-default
edit flag offensive delete link more


Thanks for the answer. I tried the above steps, the installation still returned an error. On Reboot, system fstucks at boot logo

asder gravatar imageasder ( 2018-06-25 17:24:14 -0500 )edit

After 5 minutes or so it booted black screen and X on the mouse

asder gravatar imageasder ( 2018-06-25 17:37:30 -0500 )edit

what error did the installer return?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-06-25 19:08:48 -0500 )edit

I added the screenshots of errors, I get In the main post

asder gravatar imageasder ( 2018-06-26 02:44:16 -0500 )edit

Question Tools

1 follower


Asked: 2018-06-25 14:05:56 -0500

Seen: 513 times

Last updated: Jun 26 '18