Eclipse with E(fx)lipse showing errors on nearly every action

asked 2018-06-22 06:51:12 -0500

updated 2018-11-04 03:24:20 -0500

hhlp gravatar image

After the installation of e(fx)lipse in eclipse theres an error coming up for most of the actions the IDE does. Saving, running, git check etc. Always an error telling me it didnt work evene though it did. Also the suggestions are gone completety. There is always this error shown:

com.google.common.util.concurrent.ExecutionError: com.google.common.util.concurrent.ExecutionError: java.lang.IncompatibleClassChangeError: Class org.eclipse.fx.core.guice.FXLoggerListener does not implement the requested interface com.google.inject.spi.TypeListener

I tried to reproduce this error on other systems with the same eclipse Version and wasnt successfull, so i tink its a problem with the Version in Fedora.

edit retag flag offensive close merge delete

Comments

Did you install it as a fedora rpm package?

villykruse gravatar imagevillykruse ( 2018-06-22 09:54:31 -0500 )edit