Ask Your Question

I can't install KDE to dual boot with windows 10

asked 2018-06-16 12:00:15 -0500

disco-penguin gravatar image

updated 2018-11-04 03:26:05 -0500

hhlp gravatar image

i've already followed the documentation, I downloaded the iso and then used Fedora Media Writer to make a USB stick to boot the live image from there, but i can't makev it boot from the USB in uefi mode, if i change the settings to legacy i'm able to install KDE but then windows doesn't work and if i turn back to uefi, windows works perfectly but fedora doesn't at all. I though it had to do with the secure mode, but i disabled it and it still doesn't boot from the USB. Does anyone know what I might be doing wrong? I have an Acer Aspire ES 15, windows 10 and InsydeH20 and i'm trying to install fedora KDE.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2018-06-16 17:31:50 -0500

fringmar gravatar image

updated 2018-06-16 17:39:30 -0500

From my recent experience with an Acer laptop with Windows 10, you might have to do the following to make it dual-boot in secure mode:

  • Preparation for installation: Convince the machine to boot from the USB medium in UEFI secure mode first.

    • You'll have to enter the BIOS set-up (press F2 during power-on).
    • Set a master password. If you don't plan on keeping your machine locked with a BIOS password, you can use a one-letter password and reset it later.
    • Reboot, enter the BIOS again, look through the secure boot / UEFI options and find the one where you can add allowed partitions. Find the bootable Linux on the USB medium and add it.
  • Boot from the USB drive. Install Fedora, use the settings for UEFI (can't remember whether I made it work with the automatic set-up or did a manual config). You'll want to end up with a GRUB config that contains your Windows boot loader as an option, too.

  • When rebooting, enter the BIOS again and add the new partition that contains your Fedora's GRUB to the list of allowed partitions.

  • Change the boot order so that your new Fedora GRUB is loaded first. You can then boot Windows from the GRUB menu.

Note: It's been a few months, I can't remember whether the first step (adding the USB medium first) is really necessary, but it's definitely necessary for the installed partition. Thanks for nothing, Acer.

edit flag offensive delete link more


Thank you very much, that was the correct way (even though new problems appeared but i'm not stuck anymore). You've been very helpful, thanks ๐Ÿ˜€๐Ÿ˜€

disco-penguin gravatar imagedisco-penguin ( 2018-06-28 16:56:47 -0500 )edit

answered 2018-06-16 15:41:55 -0500

revolucion09 gravatar image

updated 2018-06-16 15:43:32 -0500

The key mistake in your process is how you create the USB stick. You need to respect what you alreaady have installed, e.g.:

If you have Windows isntalled, and it is in UEFI mode, usually the disk partitioning is of type GPT (legacy usually comes with MBR disks). In this case, the USB with fedora needs to be of type UEFI/GPT. You can usually choose this at USB burning level, e.g. in windows the utility called Rufus, allows you to choose how you want to burn the USB drive.

The opposite story, if you have windows in Legacy mode, you need to burn the USB media in MBR legacy mode.

Then, install both following the same partitioning type and, if UEFI, share the UEFI partition so your new installation doesn't screw up the existing one.

PS. KDE doesn't have anything to do with any of this. Barely Fedora has anything to do at all. This is the same for any linux distribution, if not any operative system.

Good luck

edit flag offensive delete link more



The boot USB was created by the recommended Fedora Media Writer utility, and it can be booted in either mode depending on the computer's firmware. The original contents of the USB device is overwritten, including the partition table.

villykruse gravatar imagevillykruse ( 2018-06-17 00:21:49 -0500 )edit

Question Tools


Asked: 2018-06-16 12:00:15 -0500

Seen: 298 times

Last updated: Jun 16 '18