Ask Your Question
2

Cracking noise during startup and system sounds

asked 2018-05-27 17:55:45 -0500

Windam gravatar image

Hi All, I'm new to this site.. and to fedora too. I want to give it a try. I've a problem with the audio. There is (sometime... not always) a crackling sound during the system startup and when the system reproduces a sound. For example, if I keep press the backspace key when the text field is already empty, the system initially emit a crackling sound and then the sound is emitted normally. The same crackling sound is emitted during the system startup... at very early stage of the startup phase.

I'm new to fedora so, please, you ask if you want more information about my system configuration... and please give me the command to obtain that information.

Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-05-28 10:03:31 -0500

muep gravatar image

There could be many reasons for this, but there is one recent change related to power management that has a chance of causing a problem quite exactly like this.

If your audio output device is one of those controlled by the snd_hda_intel driver, please try if disabling the power management feature of that driver helps. One way to do so is to write a configuration file that adds parameters to the driver. Run this:

sudo -e /etc/modprobe.d/snd_hda_intel.conf

Then in the editor, add this content:

options snd_hda_intel power_save=0

Save the file and exit the editor, then try rebooting the computer. To verify that the power-saving feature is not enabled, run this and check that it prints a 0:

cat /sys/module/snd_hda_intel/parameters/power_save

If this does not help, it is a good idea to revert the configuration change that was created earlier, so that it does not cause confusion during later investigation of the problem:

sudo rm /etc/modprobe.d/snd_hda_intel.conf
edit flag offensive delete link more
0

answered 2018-05-30 21:01:02 -0500

LazyDragon gravatar image

my older fedora systems had this bug too. one way I was able to resolve it was to open VLC, start a video, and move the slider along the bottom back and forth.

Sometimes it would take multiple slides, back / forth, but the staticy sound would revert to clean sound.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-05-27 17:55:45 -0500

Seen: 214 times

Last updated: May 28 '18