Fedora 28 Cinnamon stuck in software rendering mode and brightness control not working

asked 2018-05-25 07:04:55 -0500

Logik gravatar image

Here is my laptop config:- https://paste.fedoraproject.org/paste....

This is pretty new machine with latest i5 8th Gen 8300H (UHD 630 onboard graphics and Nvidia 1050Ti mobile GPU). After trying about few other linux distros, I could only get fedora 28 Cinnamon running on this beast. (probably coz of kernel 4.16.x that F28 houses). But now the cinnamon is stuck in software rendering mode

Cinnamon is currently running without video hardware acceleration and, as a result, you may observe much higher than normal CPU usage. There could be a problem with your drivers or some other issue. For the best experience, it is recommended that you only use this mode for troubleshooting purposes.​

So seems the drivers for the UHD 630 aren't in place. Here are details

[root@makfed28 ~]# lspci -k
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
Subsystem: Acer Incorporated [ALI] Device 1262
Kernel modules: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
Subsystem: Acer Incorporated [ALI] Device 1263
Kernel modules: nouveau
#> lshw
*-display UNCLAIMED
                description: VGA compatible controller
                product: GP107M [GeForce GTX 1050 Ti Mobile]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list
                configuration: latency=0
                resources: memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4000000-a407ffff
        *-display UNCLAIMED
             description: VGA compatible controller
             product: Intel Corporation
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 00
             width: 64 bits
             clock: 33MHz
             capabilities: pciexpress msi pm vga_controller bus_master cap_list
             configuration: latency=0

My study shows me that from kernel 4.15.x these UHD drivers support is built in. I am running on kernel 4.16.10 here. I am not sure why I can't get cinnamon out of software rendering mode.

Here is what is appearing for i915 in dmesg

[root@makfed28 /]# dmesg | grep i915
[    3.816232] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)

Also some of the errors in dmesg are:-
[    0.069891] ACPI Error: Method parse/execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180105/psparse-550)
[    0.069899] ACPI Error: Method execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180105/uteval-103)
[    0.070656] ACPI Error: Method parse/execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180105/psparse-550)
[    0.070662] ACPI Error: Method execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180105/uteval-103)
[    0.113634] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113643] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113650] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113657] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113664] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113670] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113677] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.113684] ACPI Error: AE_NOT_FOUND, Evaluating _PRS (20180105/pci_link-176)
[    0.719048] dpc 0000:00:1d.0:pcie010: DPC error containment capabilities ...
(more)
edit retag flag offensive close merge delete